aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/python.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index e7cfdd7..8a8044c 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1703,19 +1703,26 @@ window to get to RStudio for example.")
(define-public python-flask-debugtoolbar
(package
(name "python-flask-debugtoolbar")
- (version "0.11.0")
+ (version "0.16.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Flask-DebugToolbar" version))
+ (uri (string-append
+ "https://github.com/pallets-eco/flask-debugtoolbar/archive/refs/tags/"
+ version
+ ".tar.gz"))
(sha256
(base32
- "1d5asdnk8bmh6m46pzg3i7677cjgdm9mlm3wcpk19q7dak9pjkiw"))))
- (build-system python-build-system)
+ "1qk8kga6gjlwc0c0hr1i500rhm1qfa4gqq3djy40j95fiz1idkgy"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-blinker" ,python-blinker)
("python-flask" ,python-flask)
+ ("python-flit-core" ,python-flit-core)
("python-itsdangerous" ,python-itsdangerous)
+ ("python-flask-sqlalchemy" ,python-flask-sqlalchemy)
("python-werkzeug" ,python-werkzeug)))
(home-page
"https://flask-debugtoolbar.readthedocs.io/")