aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/genenetwork.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 6e0c540..162aaa9 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -463,7 +463,8 @@
python-pytest
python-hypothesis))
(propagated-inputs
- (list gunicorn
+ (list gn-libs
+ gunicorn
nss-certs
python-redis
python-flask
@@ -485,7 +486,7 @@
(license license:agpl3+))))
(define-public gn-auth
- (let ((commit "4c21d0e43cf0de1084d0e0a243e441c6e72236eb")
+ (let ((commit "346217b95a4aac17a5c7ac05c00d1205fa1855c5")
(revision "01"))
(package
(name "gn-auth")
@@ -499,7 +500,7 @@
(hash
(content-hash
(base32
- "0z9qpgn0j9idzi975ykh04bq2r4pz5d0pppk2zvxiyhxxgxjydrx")))))
+ "0nyxml3s778zaq3r0r9z5d7010hmbzvlwdbm5xnmrzc0xlx223g3")))))
(build-system python-build-system)
(arguments
(list
@@ -517,7 +518,8 @@
python-pytest
python-pytest-mock))
(propagated-inputs
- (list gunicorn
+ (list gn-libs
+ gunicorn
nss-certs
python-blinker
python-argon2-cffi
@@ -536,7 +538,7 @@
(define-public gn-libs
- (let ((commit "eb99148991a5869cf10c241aeff6c47708986a3a")
+ (let ((commit "4d9a29862a34b6b91829b3504b339214d010d722")
(revision "01"))
(package
(name "gn-libs")
@@ -550,7 +552,7 @@
(hash
(content-hash
(base32
- "1lbvpn0ddsbj8xvnkzs352n7dg8drpvgx4j9xsxb24ny1f2ij323")))))
+ "00ms9ma1704vgwlcsr43s87hyhb5f9jcasfrn7xqldix6rq1k4g1")))))
(build-system pyproject-build-system)
(arguments
(list
@@ -565,7 +567,9 @@
python-pylint
python-pytest))
(propagated-inputs
- (list python-mysqlclient))
+ (list python-authlib
+ python-pymonad
+ python-mysqlclient))
(home-page "https://github.com/genenetwork/gn-libs")
(synopsis "Tools/utilities for GeneNetwork projects.")
(description "A collection of tools and utilities used across multiple