aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gn/packages/bioinformatics.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 397b38f..e0586fb 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -2403,10 +2403,6 @@ in-memory footprint at the cost of packing and unpacking.")
((" \\$\\(LIB_DIR\\)/libdw.a")
(string-append " " (search-input-file inputs "/lib/libdw.so")))
- ;; We need the Make.helper file in SDSL_DIR for gcsa2
- ;((" \\$\\(LIB_DIR\\)/libsdsl.a")
- ; (string-append " " (search-input-file inputs "/lib/libsdsl.so")))
-
((" \\$\\(LIB_DIR\\)/%divsufsort.a")
(string-append " " (dirname
(search-input-file inputs "/lib/libdivsufsort.so"))
@@ -2445,37 +2441,6 @@ in-memory footprint at the cost of packing and unpacking.")
(("\\$\\{sdsl-lite-divsufsort_INCLUDE\\}")
(dirname
(search-input-file inputs "/include/divsufsort.h"))))))
- #;
- (add-before 'patch-source 'use-shared-libvg
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("libvg\\.a") "libvg.so")
- ;; Have the linker find the shared library.
- (("\\$\\(LIB_DIR\\)/libvg.\\$\\(SHARED_SUFFIX\\) \\$\\(LDFLAGS\\)")
- "-lvg $(LDFLAGS)")
- (("\\$\\(LDFLAGS\\) \\$\\(LIB_DIR\\)/libvg.so")
- "$(LDFLAGS) -lvg"))
- (setenv "LDFLAGS" (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))
-
- ;; We need to tell a number of dependencies to build with -fPIC.
- (substitute* "Makefile"
- (("^CXXFLAGS := -O3")
- (string-append "CFLAGS := -fPIC\n"
- "CXXFLAGS := -O3 -fPIC"))
- (("^export CXXFLAGS")
- (string-append "export CFLAGS\n"
- "$(info CFLAGS are $(CFLAGS))\n"
- "export CXXFLAGS"))
- ((" \\$\\(LIB_DIR\\)/libjemalloc.a")
- (string-append " " (assoc-ref inputs "jemalloc")
- "/lib/libjemalloc_pic.a")))
- ;; We don't want to pull in all the global CXXFLAGS here.
- (substitute* "deps/sublinear-Li-Stephens/makefile"
- (("^CXXFLAGS:=") "CXXFLAGS:= -fPIC "))
- ;; CMAKE_CXX_FLAGS aren't set globally.
- (substitute* "deps/kff-cpp-api/CMakeLists.txt"
- (("CMAKE_CXX_FLAGS \"") "CMAKE_CXX_FLAGS \" -fPIC "))))
(add-after 'unpack 'dont-build-shared-vgio
(lambda _
;; vg will link with libvgio and fail the 'validate-runpath phase.
@@ -2529,7 +2494,6 @@ in-memory footprint at the cost of packing and unpacking.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(install-file "bin/vg" (string-append out "/bin"))
- ;(install-file "lib/libvg.so" (string-append out "/lib"))
(for-each
(lambda (file)
(install-file file (string-append out "/share/man/man1")))