aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorEfraim Flashner2022-06-01 12:19:31 +0300
committerEfraim Flashner2022-06-01 12:19:50 +0300
commitfd8f6bf959fd73444bd337de9a36ed1660180a8d (patch)
tree7bcb072dbe55e2c11bacdb75c9d107b5347096c6 /gn
parente5bdf3309e1bdd6ea9c33ae3513969db768a3cde (diff)
downloadguix-bioinformatics-fd8f6bf959fd73444bd337de9a36ed1660180a8d.tar.gz
gn: Adjust vg for other architectures
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bioinformatics.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 536098c..f81c7aa 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -1659,9 +1659,18 @@ available to other researchers.")
"deps/libvgio/include/handlegraph")))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
+ ,@(if (target-riscv64?)
+ ;; riscv64 doesn't take '-march=native. This needs to be removed
+ ;; for all architectures if/when vg is upstreamed.
+ `((add-after 'unpack 'dont-build-native
+ (lambda _
+ (substitute* (append (find-files "." "CMakeLists\\.txt")
+ (find-files "." "Makefile"))
+ (("-march=native") "")))))
+ '())
(add-after 'unpack 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
@@ -1769,8 +1778,9 @@ available to other researchers.")
(substitute* "Makefile"
((".*test-docs.*") "")))))
(add-after 'build 'build-manpages
- (lambda _
- (invoke "make" "man")))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (when (assoc-ref inputs "asciidoctor")
+ (invoke "make" "man"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))