aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorEfraim Flashner2023-09-24 12:55:44 +0300
committerEfraim Flashner2023-09-24 12:55:44 +0300
commitd73c21e18365433b78ae5f92d80919ed8f6caa04 (patch)
tree0838c455e28999941e1cfa3926f501989d2c5cd4 /gn
parent08c989ee9a328ce5a26cc34a95d71a5c92cfa09e (diff)
downloadguix-bioinformatics-d73c21e18365433b78ae5f92d80919ed8f6caa04.tar.gz
seqwish: Link with sdsl-lib
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bioinformatics.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index c4463a2..a043358 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -1637,6 +1637,19 @@ runApp(launch.browser=0, port=4208)~%\n"
(else '())))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'link-with-some-shared-libraries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("CMakeLists.txt"
+ "deps/mmmulti/CMakeLists.txt")
+ (("\".*libsdsl\\.a\"") "\"-lsdsl\"")
+ (("\".*libdivsufsort\\.a\"") "\"-ldivsufsort\"")
+ (("\".*libdivsufsort64\\.a\"") "\"-ldivsufsort64\"")
+ (("\\$\\{sdsl-lite_INCLUDE\\}")
+ (string-append (assoc-ref inputs "sdsl-lite")
+ "/include/sdsl"))
+ (("\\$\\{sdsl-lite-divsufsort_INCLUDE\\}")
+ (string-append (assoc-ref inputs "libdivsufsort")
+ "/include")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
;; Add seqwish to the PATH for the tests.
@@ -1646,6 +1659,9 @@ runApp(launch.browser=0, port=4208)~%\n"
(invoke "make"))))))))
(inputs
(list jemalloc
+ libdivsufsort
+ openmpi
+ sdsl-lite
zlib))
(native-inputs
(list perl))