aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorArun Isaac2024-02-29 01:14:44 +0000
committerArun Isaac2024-02-29 01:14:44 +0000
commit2c1db30bc59441fc3e964bd30de55667ecd752c9 (patch)
tree27ba9d71b35809b784fb5cef5c37c3842c42f1e1 /gn
parentb8eac8a000f1c2de203281b3c016fe959fcff7a4 (diff)
downloadguix-bioinformatics-2c1db30bc59441fc3e964bd30de55667ecd752c9.tar.gz
gnu: Add globus-cli.
* gn/packages/globus.scm (globus-cli): New variable.
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/globus.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gn/packages/globus.scm b/gn/packages/globus.scm
index af296f3..56d2c35 100644
--- a/gn/packages/globus.scm
+++ b/gn/packages/globus.scm
@@ -47,3 +47,30 @@ Globus APIs.")
(description "@code{python-click-type-test} allows you to test that your click
options and arguments match your type annotations.")
(license license:expat)))
+
+(define-public globus-cli
+ (package
+ (name "globus-cli")
+ (version "3.25.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "globus-cli" version))
+ (sha256
+ (base32
+ "05div2psajmqdy9md804q4x6ha4yfp4w6yrxz0ynsq3i62a6cl5v"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f))
+ (propagated-inputs
+ (list python-click
+ python-cryptography
+ python-globus-sdk
+ python-jmespath
+ python-packaging
+ python-requests
+ python-typing-extensions))
+ (home-page "https://docs.globus.org/cli")
+ (synopsis "Globus CLI")
+ (description "@code{python-globus-sdk} provides a command-line interface to
+Globus APIs.")
+ (license license:asl2.0)))