aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorAlexander_Kabui2025-02-28 16:15:56 +0300
committerMunyoki Kilyungi2025-03-01 07:37:28 +0300
commit1be61b6db6ff32cef5a0e51a938cbcbc799e78ea (patch)
treeb5fddb442ce571c57eca5625b1996713dd89d2d7 /gn
parent2afaf2766bc6df32248cd9050a77dd36fd43327d (diff)
downloadguix-bioinformatics-1be61b6db6ff32cef5a0e51a938cbcbc799e78ea.tar.gz
gn: Add python-pillow-9.
* gn/packages/python.scm (python-pillow-9): New variable. Signed-off-by: Munyoki Kilyungi <me@bonfacemunyoki.com>
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/python.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 8a8044c..7cb5d77 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1962,3 +1962,60 @@ and messages in larger desktop or server-based applications.")
implementation of the built-in float which supports formatted output with
SI (decimal) and IEC (binary) prefixes.")
(license license:mpl2.0)))
+
+
+(define-public python-pillow-9
+ (package
+ (name "python-pillow-9")
+ (version "9.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pillow" version))
+ (sha256
+ (base32 "011wgm1mssjchpva9wsi2a07im9czyjvik137xlp5f0g7vykdrkm"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (delete-file-recursively "src/thirdparty")))
+ (patches (search-patches "python-pillow-CVE-2022-45199.patch"
+ ;; Included in 10.1.0.
+ "python-pillow-use-zlib-1.3.patch"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (inputs (list freetype
+ lcms
+ libjpeg-turbo
+ libtiff
+ libwebp
+ openjpeg
+ zlib))
+ (propagated-inputs (list python-olefile))
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-ldconfig
+ (lambda _
+ (substitute* "setup.py"
+ (("\\['/sbin/ldconfig', '-p'\\]")
+ "['true']"))))
+ (replace 'check
+ (lambda* (#:key outputs inputs tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME"
+ (getcwd))
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (home-page "https://python-pillow.org")
+ (synopsis "Fork of the Python Imaging Library")
+ (description
+ "The Python Imaging Library adds image processing capabilities to your
+Python interpreter. This library provides extensive file format support, an
+efficient internal representation, and fairly powerful image processing
+capabilities. The core image library is designed for fast access to data
+stored in a few basic pixel formats. It should provide a solid foundation for
+a general image processing tool.")
+ (properties `((cpe-name . "pillow")))
+ (license (license:x11-style
+ "http://www.pythonware.com/products/pil/license.htm"
+ "The PIL Software License"))))