aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
authorArun Isaac2023-10-19 15:14:48 +0100
committerArun Isaac2023-10-19 15:15:52 +0100
commitd523b0ef610ff0e3cd3c0a53f74461c377686983 (patch)
tree9e58e7c032953ee7c853df2816e340b07bd823d3 /gn/packages
parentdab19f78848da9c176238cc1eec486964a54dfca (diff)
downloadguix-bioinformatics-d523b0ef610ff0e3cd3c0a53f74461c377686983.tar.gz
Remove python-arvados-python-client.
The package is broken, some of its inputs have been removed from upstream Guix, and we no longer need this package. Restore it later if necessary. * gn/packages/python.scm (python-arvados-python-client): Delete variable.
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/python.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 020a6a9..c23d894 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -864,50 +864,6 @@ spreadsheets without the need for COM objects.")
(description "Extensions to the standard Python datetime module")
(license license:bsd-3)))
-(define-public python-arvados-python-client
- (package
- (name "python-arvados-python-client")
- (version "2.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "arvados-python-client" version))
- (sha256
- (base32 "1j08aykj0v2z2bqwr5nfnbjgc1yzdnfdafcnxbf2jbwqh8kx7zc9"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "setup.py"
- ;; Don't set a maximum version of pycurl.
- (("(pycurl >=([[:digit:]]+\\.?)+),.*" _ pycurl)
- (string-append pycurl "',\n")))))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; tests not included?
- (propagated-inputs
- (list python-ciso8601
- python-future
- python-google-api-client
- python-google-api-core-1
- python-google-auth-1
- python-httplib2
- python-protobuf
- python-pycurl
- python-pyparsing-2.4.7 ; < 3
- python-ruamel.yaml
- python-ws4py))
- (native-inputs
- (list python-mock
- python-pbr-1.6.0
- python-pyyaml))
- (home-page "https://arvados.org")
- (synopsis "Arvados client library")
- (description "This package provides the arvados module, an API client for
-Arvados. It also includes higher-level functions to help you write Crunch
-scripts, and command-line tools to store and retrieve data in the Keep storage
-server.")
- (license license:asl2.0)))
-
(define-public python-pyshex
(package
(name "python-pyshex")