aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
authorArun Isaac2024-03-11 19:06:15 +0000
committerArun Isaac2024-03-11 19:06:15 +0000
commita32299d4d002485e8b8142a14b21d46d2bb3f989 (patch)
tree015654a01c4a494204e95d399db00f39c26e8690 /gn/packages
parentfc04f7328522c4ca8b728bd129c53f26d2857d37 (diff)
downloadguix-bioinformatics-a32299d4d002485e8b8142a14b21d46d2bb3f989.tar.gz
gn: Add python-prefixed.
* gn/packages/python.scm (python-prefixed): New variable.
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index a9cd5be..e7cfdd7 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1937,3 +1937,21 @@ of a given topic, all inside the same process. The package also supports a
variety of advanced features that facilitate debugging and maintaining topics
and messages in larger desktop or server-based applications.")
(license license:bsd-2)))
+
+(define-public python-prefixed
+ (package
+ (name "python-prefixed")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "prefixed" version))
+ (sha256
+ (base32
+ "1sdvxwy4kvcxvnq1nx70j1ccx5ga6wdb478vqd5azf1fc1gd2m0b"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/Rockhopper-Technologies/prefixed")
+ (synopsis "Prefixed alternative numeric library")
+ (description "@code{python-prefixed} provides an alternative
+implementation of the built-in float which supports formatted output with
+SI (decimal) and IEC (binary) prefixes.")
+ (license license:mpl2.0)))