aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner2023-09-19 19:00:45 +0300
committerEfraim Flashner2023-09-19 19:02:20 +0300
commit8885768936858286babae788a5dcfb01c2cad0a8 (patch)
treef31ee19ee72f6f4ed551e8d86e3735349bd198a3
parent7daf6ae8cb057bc1fec076c8fb73d1e0dc2864b9 (diff)
downloadguix-bioinformatics-8885768936858286babae788a5dcfb01c2cad0a8.tar.gz
gfaffix: Update to 0.1.5.
-rw-r--r--gn/packages/bioinformatics.scm22
-rw-r--r--gn/packages/crates-io.scm4
2 files changed, 7 insertions, 19 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index db420b7..63934fc 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -469,7 +469,7 @@ reads.")
(define-public gfaffix
(package
(name "gfaffix")
- (version "0.1.3")
+ (version "0.1.5")
(source
(origin
(method git-fetch)
@@ -478,12 +478,7 @@ reads.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1biss5qv6ag1dfkn1nspwd528hpzgn8i4jydvbv2z7yv7sc685rh"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "Cargo.toml"
- (("^handlegraph.*") "handlegraph = \"0.7\"\n"))))))
+ (base32 "181jxl8ldj39jgscyqzhz4l4k5kxj1j9hvzi8dxj59h2zzznb0kb"))))
(build-system cargo-build-system)
(arguments
`(#:install-source? #f
@@ -491,19 +486,12 @@ reads.")
(("rust-clap" ,rust-clap-3)
("rust-rustc-hash" ,rust-rustc-hash-1)
("rust-regex" ,rust-regex-1)
- ("rust-handlegraph" ,rust-handlegraph-0.7)
+ ("rust-handlegraph" ,rust-handlegraph-0.7.0-alpha.9)
("rust-gfa" ,rust-gfa-0.10)
("rust-quick-csv", rust-quick-csv-0.1)
+ ("rust-rayon" ,rust-rayon-1)
("rust-log" ,rust-log-0.4)
- ("rust-env-logger" ,rust-env-logger-0.7))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'adjust-dependency-version
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((handlebar-version ,(package-version rust-handlegraph-0.7)))
- (substitute* "Cargo.toml"
- (("\"0.7\"")
- (string-append "{ version = \"" handlebar-version "\" }")))))))))
+ ("rust-env-logger" ,rust-env-logger-0.7))))
(home-page "https://github.com/marschall-lab/GFAffix")
(synopsis "Identify walk-preserving shared affixes in variation graphs")
(description
diff --git a/gn/packages/crates-io.scm b/gn/packages/crates-io.scm
index 7e74b60..a0e31ce 100644
--- a/gn/packages/crates-io.scm
+++ b/gn/packages/crates-io.scm
@@ -144,7 +144,7 @@ functions} for a collection of hashable objects.")
"Library for working with graphs in the GFA (Graphical Fragment Assembly) format")
(license license:expat)))
-(define-public rust-handlegraph-0.7
+(define-public rust-handlegraph-0.7.0-alpha.9
(package
(name "rust-handlegraph")
(version "0.7.0-alpha.9")
@@ -180,7 +180,7 @@ functions} for a collection of hashable objects.")
(define-public rust-handlegraph-0.3
(package
- (inherit rust-handlegraph-0.7)
+ (inherit rust-handlegraph-0.7.0-alpha.9)
(name "rust-handlegraph")
(version "0.3.0")
(source (origin