aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner2022-03-23 09:40:39 +0200
committerEfraim Flashner2022-03-23 09:41:09 +0200
commit393ea58b0bce8c2c4a363f7acf852cdb9f5fb996 (patch)
treefeb0ae300906e2f5fe04d812e1ffd95dd153d4e1
parentb7c869b8da2d640b213b5494865e8a756414632a (diff)
downloadguix-bioinformatics-393ea58b0bce8c2c4a363f7acf852cdb9f5fb996.tar.gz
gn: gem5: unbundle pybind11
-rw-r--r--VERSION2
-rw-r--r--gn/packages/virtualization.scm10
2 files changed, 10 insertions, 2 deletions
diff --git a/VERSION b/VERSION
index 868c742..55f4bc9 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-61b4b6aea29b24f4a1c6af7d8f4e1c416ab41c86
+fada73a28020a2996c708d8c0a992d38a2cdd05d
diff --git a/gn/packages/virtualization.scm b/gn/packages/virtualization.scm
index 5421a2b..aa22349 100644
--- a/gn/packages/virtualization.scm
+++ b/gn/packages/virtualization.scm
@@ -81,7 +81,13 @@ systems. It is designed to host the RISC-V Linux port.")
;; For reproducibility.
(substitute* "src/base/date.cc"
(("__DATE__") "\"1970-01-01\"")
- (("__TIME__") "\"00:00:00\""))))))
+ (("__TIME__") "\"00:00:00\""))
+ (substitute* "ext/sst/Makefile"
+ (("-I../../ext/pybind11/include/")
+ "${shell pybind11-config --includes}"))
+ (substitute* "SConstruct"
+ ((".*pybind11.*") ""))
+ (delete-file-recursively "ext/pybind11")))))
(build-system scons-build-system)
(arguments
`(#:scons-flags
@@ -108,6 +114,7 @@ systems. It is designed to host the RISC-V Linux port.")
(string-append
all (assoc-ref inputs "kernel-headers") "/include')])\n"
all (assoc-ref inputs "libpng") "/include')])\n"
+ all (assoc-ref inputs "pybind11") "/include')])\n"
all (assoc-ref inputs "zlib") "/include')])\n"
all)))
(substitute* "ext/libelf/SConscript"
@@ -146,6 +153,7 @@ systems. It is designed to host the RISC-V Linux port.")
(list gperftools
libpng
protobuf
+ pybind11
python
python-pydot
python-six