diff options
author | Frederick Muriuki Muriithi | 2024-03-08 02:37:00 +0300 |
---|---|---|
committer | Frederick Muriuki Muriithi | 2024-03-08 02:48:10 +0300 |
commit | 6ced7085193affa636f229e72dc19175a3a06cfe (patch) | |
tree | 98f21fb4b267e93f1fb155684a6804d297e454d9 /setup.py | |
parent | fc59312e3ff124f76c0646a5ce88b419ca3621bb (diff) | |
download | gn-uploader-6ced7085193affa636f229e72dc19175a3a06cfe.tar.gz |
Update packaging and distribution declarations.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 35 |
1 files changed, 33 insertions, 2 deletions
@@ -1,4 +1,35 @@ """The setup module""" -from setuptools import setup +from setuptools import setup, find_packages -setup() +LONG_DESCRIPTION=""" +gn-uploader is a service allowing upload of new data into GeneNetwork. It +performs quality control on the data that is being uploaded to ensure it meets +all conditions before it can be accepted. +""" + +setup( + name="gn-uploader", + version="0.1.0", + description="Data uploader and quality-control application.", + long_description=LONG_DESCRIPTION, + long_description_content_type="text/plain", + author="Frederick M. Muriithi", + author_email="fredmanglis@gmail.com", + url="https://git.genenetwork.org/gn-uploader", + include_package_data=True, + packages=find_packages( + where=".", exclude=("tests", "tests.*")), + scripts=[], + license="AGPLV3", + install_requires=[ + "redis", + "Flask", + "pyyaml", + "gunicorn", + "jsonpickle", + "mysqlclient"], + tests_require=[ + "mypy", + "pylint", + "pytest", + "hypothesis"]) |