aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bioinformatics.scm52
-rw-r--r--gn/packages/statistics.scm83
2 files changed, 0 insertions, 135 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 2dcaf62..5c9a5f3 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -720,58 +720,6 @@ length of a short-read sequencing alignment.")
"A library of core preprocessing routines.")
(license license:lgpl2.0+)))
-(define-public r-wgcna
- (let ((commit "425bc170cc0873ddbd414675ac40f6d4d724c7cb"))
-(package
- (name "r-wgcna")
- (version (string-append "1.49-" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- ;; (url "https://github.com/genenetwork/WGCNA.git")
- (url "https://github.com/pjotrp/WGCNA.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "1zqnsb8s3065rq1y2y3l79zi8wmdwjkcjls96ypycrb7pmdil58j"))))
- (properties `((upstream-name . "WGCNA")))
- (build-system r-build-system)
- (propagated-inputs
- `( ;; ("r-annotationdbi" ,r-annotationdbi)
- ; ("r-biocparallel" ,r-biocparallel)
- ("r-doparallel" ,r-doparallel)
- ("r-dynamictreecut" ,r-dynamictreecut)
- ("r-fastcluster" ,r-fastcluster)
- ("r-foreach" ,r-foreach)
- ("r-go-db" ,r-go-db)
- ; ("r-grdevices" ,r-grdevices)
- ("r-hmisc" ,r-hmisc)
- ("r-impute" ,r-impute)
- ("r-matrixstats" ,r-matrixstats)
- ; ("r-parallel" ,r-parallel)
- ("r-biocpreprocesscore" ,r-biocpreprocesscore)
- ; ("r-splines" ,r-splines)
- ; ("r-stats" ,r-stats)
- ; ("r-survival" ,r-survival)
- ; ("r-utils" ,r-utils)
- ))
- (arguments
- `(
- #:tests? #f)) ; no 'setup.py test'
- (home-page
- "http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/Rpackages/WGCNA/")
- (synopsis
- "Weighted gene correlation network analysis (wgcna)")
- (description
- "Functions necessary to perform Weighted Correlation Network
-Analysis on high-dimensional data. Includes functions for rudimentary
-data cleaning, construction of correlation networks, module
-identification, summarization, and relating of variables and modules
-to sample traits. Also includes a number of utility functions for
-data manipulation and visualization.")
- (license license:gpl2+))))
-
(define-public plink2
(package
(name "plink2")
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index b83ccf2..50604ef 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -111,46 +111,6 @@
(license #f))
)
-(define-public r-hmisc
-(package
- (name "r-hmisc")
- (version "3.17-2")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "Hmisc" version))
- (sha256
- (base32
- "110w5hbrl10isslqs0iq6w2ll0dafqyqznb50cdcallnlnvbvxrg"))))
- (properties `((upstream-name . "Hmisc")))
- (build-system r-build-system)
- (inputs
- `(("gfortran" ,gfortran)))
- (arguments
- `(#:tests? #f)) ; no 'setup.py test'
- (propagated-inputs
- `(("r-acepack" ,r-acepack)
- ; ("r-cluster" ,r-cluster)
- ; ("r-foreign" ,r-foreign)
- ("r-formula" ,r-formula)
- ("r-ggplot2" ,r-ggplot2)
- ; ("r-grid" ,r-grid)
- ("r-gridextra" ,r-gridextra)
- ("r-gtable" ,r-gtable)
- ("r-lattice" ,r-lattice)
- ("r-latticeextra" ,r-latticeextra)
- ; ("r-methods" ,r-methods)
- ; ("r-nnet" ,r-nnet)
- ; ("r-rpart" ,r-rpart)
- ; ("r-survival" ,r-survival)))
- ))
- (home-page
- "http://biostat.mc.vanderbilt.edu/Hmisc")
- (synopsis "Harrell Miscellaneous")
- (description
- "Contains many functions useful for data analysis, high-level graphics, utility operations, functions for computing sample size and power, importing and annotating datasets, imputing missing values, advanced table making, variable clustering, character string manipulation, conversion of R objects to LaTeX code, and recoding variables.")
- (license license:gpl2+)))
-
(define-public r-iterators
(package
(name "r-iterators")
@@ -171,49 +131,6 @@
"Support for iterators, which allow a programmer to traverse through all the elements of a vector, list, or other collection of data.")
(license #f)))
-(define-public r-fastcluster
-(package
- (name "r-fastcluster")
- (version "1.1.16")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "fastcluster" version))
- (sha256
- (base32
- "0x2prrsnqi5iqx23ki6y2agndjq8058ph6s703i4avrqi1q1w1q8"))))
- (build-system r-build-system)
- (home-page
- "http://danifold.net/fastcluster.html")
- (synopsis
- "Fast Hierarchical Clustering Routines for R and Python")
- (description
- "This is a two-in-one package which provides interfaces to both R and Python. It implements fast hierarchical, agglomerative clustering routines. Part of the functionality is designed as drop-in replacement for existing routines: \"linkage\" in the SciPy package \"scipy.cluster.hierarchy\", \"hclust\" in R's \"stats\" package, and the \"flashClust\" package. It provides the same functionality with the benefit of a much faster implementation. Moreover, there are memory-saving routines for clustering of vector data, which go beyond what the existing packages provide. For information on how to install the Python files, see the file INSTALL in the source distribution.")
- (license #f)))
-
-(define-public r-dynamictreecut
-(package
- (name "r-dynamictreecut")
- (version "1.62")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "dynamicTreeCut" version))
- (sha256
- (base32
- "1y11gg6k32wpsyb10kdv176ivczx2jlizs1xsrjrs6iwbncwzrkp"))))
- (properties
- `((upstream-name . "dynamicTreeCut")))
- (build-system r-build-system)
- ; (propagated-inputs `(("r-stats" ,r-stats)))
- (home-page
- "http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/BranchCutting/")
- (synopsis
- "Methods for detection of clusters in hierarchical clustering dendrograms.")
- (description
- "Contains methods for detection of clusters in hierarchical clustering dendrograms.")
- (license license:gpl2+)))
-
(define-public r-rcppeigen
(package
(name "r-rcppeigen")