aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/genenetwork.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gn/packages/genenetwork.scm')
-rw-r--r--gn/packages/genenetwork.scm77
1 files changed, 58 insertions, 19 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index a555a59..7116156 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages serialization)
#:use-module (gn packages bioinformatics)
#:use-module (gn packages crates-io)
#:use-module (gn packages gemma)
@@ -115,7 +116,7 @@
((#:tests? _ #f) #f)))))
(define-public genenetwork3
- (let ((commit "0d902ec267d96b87648669a7a43b699c8a22a3de")
+ (let ((commit "b13447ff27581b2018e374e1d672dd680f06f177")
(revision "5"))
(package
(name "genenetwork3")
@@ -129,7 +130,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "159f6h2jcc6ydb8xwnjaqksbp52ycjwnf10bcy6fd2zvh1g8bjad"))))
+ "0xpcrsigk1fprhbz53rdyxchxvbjkcy2dmi0b3w9sg701q6bjlkg"))))
(inputs
(list python-click))
(native-inputs
@@ -191,8 +192,39 @@
(description "GeneNetwork3 API for data science and machine learning.")
(license license:agpl3+))))
+
+(define-public temporary-python-flask-session
+ ;; This is a stop-gap to get the applications building with the guix channel
+ ;; set to 61428cc.
+ ;; Remove this as soon as the applications are building with mainline
+ ;; python-flask-session.
+ (package
+ (name "temporary-python-flask-session")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask_session" version))
+ (sha256
+ (base32
+ "1zs20zpq6gxz9gsccbd2jrrbbcfvh0x9z9741gkr8dhh07mlbq10"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests require the various storage backends to be present
+ (inputs
+ (list python-flit-core))
+ (propagated-inputs
+ (list python-cachelib python-flask python-msgspec))
+ (home-page "https://github.com/fengsp/flask-session")
+ (synopsis "Adds server-side session support to your Flask application")
+ (description
+ "Flask-Session is an extension for Flask that adds support for
+Server-side sessions, with a variety of different backends for session
+storage.")
+ (license license:bsd-3)))
+
(define-public genenetwork2
- (let ((commit "314c6d597a96ac903071fcb6e50df3d9e88935e9")
+ (let ((commit "ffc39ef4b9d850375888161d0f38f797ce37e785")
(revision "4"))
(package
(name "genenetwork2")
@@ -205,7 +237,7 @@
(file-name (string-append name "-" version))
(sha256
(base32
- "143a1b9jr5f0c184j06szrg6ly7kd2fn547pmb97iya658zai7gq"))))
+ "0b7dzbg5zzpm9p98047n36wwc25gfwr7hb2ns8l4z586p06m1yph"))))
(native-inputs
(list graphviz))
(propagated-inputs
@@ -267,6 +299,8 @@
javascript-uikit
javascript-underscore-string
javascript-zxcvbn
+ javascript-xterm
+ javascript-xterm-style
js-jstat
js-md5
js-parsley
@@ -284,7 +318,8 @@
python-cssselect
python-flask
python-flask-debugtoolbar
- python-flask-session
+ ;;python-flask-session
+ temporary-python-flask-session
python-htmlgen
python-ijson
python-jinja2
@@ -294,7 +329,6 @@
python-mysqlclient
python-numpy
python-pandas
- python-pillow
python-pylint
python-pymonad
python-pytest
@@ -306,9 +340,9 @@
python-scipy
python-setuptools
python-simplejson
- python-sqlalchemy
python-wrapper
python-xlsxwriter
+ python-pillow-9
r
r-ctl
r-qtl
@@ -316,8 +350,6 @@
redis
rust-qtlreaper
which
- ; javascript-xterm -- disabled until we know what to do with it, not working on production
- ; javascript-xterm-style
; javascript-xterm-addon-fit
))
(inputs
@@ -436,8 +468,8 @@
))))))
(define-public gn-uploader
- (let ((commit "848bd536ce8d34f0b1ddada7b170f56f6465b317")
- (version "0.1.0"))
+ (let ((commit "a675d462d2771f9e6c497c2385c985c2a6bb8806")
+ (version "0.1.1"))
(package
(name "gn-uploader")
(version (string-append version "-" (string-take commit 8)))
@@ -447,10 +479,11 @@
(uri (git-reference
(url "https://git.genenetwork.org/gn-uploader")
(commit commit)))
+ (file-name (git-file-name name version))
(hash
(content-hash
(base32
- "1qlimmbb820q1w76iv3bid5vv29rwrdd0xk3jskqg66v9yirqqyi")))))
+ "0wa5ww43jimwgw9wvz5rmpxhva0fvbd5cqaf6m6d2d57v4klapsi")))))
(build-system python-build-system)
(arguments
(list
@@ -476,10 +509,14 @@
python-pymonad
python-jsonpickle
python-mysqlclient
- python-flask-session
- javascript-jquery
- javascript-bootstrap
- javascript-datatables
+ ;;python-flask-session
+ temporary-python-flask-session
+ web-bootstrap-5
+ javascript-jquery-1
+ javascript-datatables-bootstrap5
+ javascript-datatables-select
+ javascript-datatables-buttons-3
+ javascript-datatables-scroller-2
node-resumablejs))
(synopsis "GeneNetwork Quality Control Application")
(description
@@ -490,7 +527,7 @@
(license license:agpl3+))))
(define-public gn-auth
- (let ((commit "e345a04030249c99237a7f4e1e80e29918e99c7c")
+ (let ((commit "8ff5d551633177d5ff07544348b2e04c4de5654e")
(revision "01"))
(package
(name "gn-auth")
@@ -504,7 +541,7 @@
(hash
(content-hash
(base32
- "17srcxk5zwnsx97jqmg1csarmjsny8z8k7q435kq19p472f27yv7")))))
+ "1pjcbrvmqipbni65ffq808gxzh2ywdwi28pm3gfqwq1z1jf627sx")))))
(build-system python-build-system)
(arguments
(list
@@ -568,8 +605,10 @@
(invoke "pytest" "-k" "unit_test")))))))
(native-inputs
(list python-mypy
+ python-wheel
python-pylint
- python-pytest))
+ python-pytest
+ python-setuptools))
(propagated-inputs
(list python-authlib
python-pymonad