aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/statistics.scm
diff options
context:
space:
mode:
authorPjotr Prins2019-02-17 02:23:14 -0600
committerPjotr Prins2019-02-17 02:23:14 -0600
commitebc8b321c367c71f39bf4034caec3bf3341afc5e (patch)
treebb114f99caf27b9c0c31b5c4250ed3bfcc58eaac /gn/packages/statistics.scm
parent7a5ba50f1df5473bf43abeae34648ee39698a6b1 (diff)
downloadguix-bioinformatics-ebc8b321c367c71f39bf4034caec3bf3341afc5e.tar.gz
Fix GN2 build - but need to enable RPy2 tests again
Diffstat (limited to 'gn/packages/statistics.scm')
-rw-r--r--gn/packages/statistics.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index ee10224..cdabf69 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -274,46 +274,6 @@
"Data and Functions from the book R Graphics, Second Edition. There is a function to produce each figure in the book, plus several functions, classes, and methods defined in Chapter 8.")
(license license:gpl2+)))
-(define-public pylmm-gn2
- (let ((commit "3c6d1cac8"))
- (package
- (name "pylmm-gn2")
- (version (string-append "1.0-" commit ))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/genenetwork/pylmm.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "0wryaadb36i275p9d2i1kzflahvbl9kj5wlk8jlbvjij8gpqg964"))))
- (build-system python-build-system)
- (inputs `(
- ("python2-setuptools" ,python2-setuptools)
- ("python2-scipy" ,python2-scipy)
- ("python2-numpy" ,python2-numpy)
- ))
- (arguments
- `(#:python ,python-2
- #:tests? #f ; no 'setup.py test'
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'change-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "scripts/pylmm_redis"
- (("/usr/bin/python") (which "python"))
- (("\\$PACKAGEDIR") (string-append out "/lib/python2.7/site-packages")))
- ))))))
-
- (home-page "http://genenetwork.org/")
- (synopsis "LMM resolver")
- (description "Fast and lightweight linear mixed-model (LMM) solver
-for use in genome-wide association studies (GWAS).")
- (license license:agpl3+))))
-
(define-public r-ctl ; guix: ready
(package
(name "r-ctl")