aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/statistics.scm
diff options
context:
space:
mode:
authorPjotr Prins2017-02-18 05:17:23 -0600
committerPjotr Prins2017-02-18 05:17:23 -0600
commit0747984b10a05d674d34bc5491e76e6d8f39989c (patch)
tree015cff8ec9f4e38384ebb7316e1c828811e2eeb3 /gn/packages/statistics.scm
parentea1ce997a5e43e1993864464e1a1d45e9b20c8db (diff)
downloadguix-bioinformatics-0747984b10a05d674d34bc5491e76e6d8f39989c.tar.gz
Removed packages that appear in guix master
Diffstat (limited to 'gn/packages/statistics.scm')
-rw-r--r--gn/packages/statistics.scm83
1 files changed, 0 insertions, 83 deletions
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index b83ccf2..50604ef 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -111,46 +111,6 @@
(license #f))
)
-(define-public r-hmisc
-(package
- (name "r-hmisc")
- (version "3.17-2")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "Hmisc" version))
- (sha256
- (base32
- "110w5hbrl10isslqs0iq6w2ll0dafqyqznb50cdcallnlnvbvxrg"))))
- (properties `((upstream-name . "Hmisc")))
- (build-system r-build-system)
- (inputs
- `(("gfortran" ,gfortran)))
- (arguments
- `(#:tests? #f)) ; no 'setup.py test'
- (propagated-inputs
- `(("r-acepack" ,r-acepack)
- ; ("r-cluster" ,r-cluster)
- ; ("r-foreign" ,r-foreign)
- ("r-formula" ,r-formula)
- ("r-ggplot2" ,r-ggplot2)
- ; ("r-grid" ,r-grid)
- ("r-gridextra" ,r-gridextra)
- ("r-gtable" ,r-gtable)
- ("r-lattice" ,r-lattice)
- ("r-latticeextra" ,r-latticeextra)
- ; ("r-methods" ,r-methods)
- ; ("r-nnet" ,r-nnet)
- ; ("r-rpart" ,r-rpart)
- ; ("r-survival" ,r-survival)))
- ))
- (home-page
- "http://biostat.mc.vanderbilt.edu/Hmisc")
- (synopsis "Harrell Miscellaneous")
- (description
- "Contains many functions useful for data analysis, high-level graphics, utility operations, functions for computing sample size and power, importing and annotating datasets, imputing missing values, advanced table making, variable clustering, character string manipulation, conversion of R objects to LaTeX code, and recoding variables.")
- (license license:gpl2+)))
-
(define-public r-iterators
(package
(name "r-iterators")
@@ -171,49 +131,6 @@
"Support for iterators, which allow a programmer to traverse through all the elements of a vector, list, or other collection of data.")
(license #f)))
-(define-public r-fastcluster
-(package
- (name "r-fastcluster")
- (version "1.1.16")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "fastcluster" version))
- (sha256
- (base32
- "0x2prrsnqi5iqx23ki6y2agndjq8058ph6s703i4avrqi1q1w1q8"))))
- (build-system r-build-system)
- (home-page
- "http://danifold.net/fastcluster.html")
- (synopsis
- "Fast Hierarchical Clustering Routines for R and Python")
- (description
- "This is a two-in-one package which provides interfaces to both R and Python. It implements fast hierarchical, agglomerative clustering routines. Part of the functionality is designed as drop-in replacement for existing routines: \"linkage\" in the SciPy package \"scipy.cluster.hierarchy\", \"hclust\" in R's \"stats\" package, and the \"flashClust\" package. It provides the same functionality with the benefit of a much faster implementation. Moreover, there are memory-saving routines for clustering of vector data, which go beyond what the existing packages provide. For information on how to install the Python files, see the file INSTALL in the source distribution.")
- (license #f)))
-
-(define-public r-dynamictreecut
-(package
- (name "r-dynamictreecut")
- (version "1.62")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "dynamicTreeCut" version))
- (sha256
- (base32
- "1y11gg6k32wpsyb10kdv176ivczx2jlizs1xsrjrs6iwbncwzrkp"))))
- (properties
- `((upstream-name . "dynamicTreeCut")))
- (build-system r-build-system)
- ; (propagated-inputs `(("r-stats" ,r-stats)))
- (home-page
- "http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/BranchCutting/")
- (synopsis
- "Methods for detection of clusters in hierarchical clustering dendrograms.")
- (description
- "Contains methods for detection of clusters in hierarchical clustering dendrograms.")
- (license license:gpl2+)))
-
(define-public r-rcppeigen
(package
(name "r-rcppeigen")