aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/python.scm
diff options
context:
space:
mode:
authorArun Isaac2024-03-11 19:05:58 +0000
committerArun Isaac2024-03-11 19:05:58 +0000
commite84620e6d91e2cbd7aa683846ccb9664ae9137eb (patch)
tree03462238f4e8b38cde779dc7e110163c4fb7e318 /gn/packages/python.scm
parent88bbef10dfd95637c65a2392b54b426dbed78c4c (diff)
downloadguix-bioinformatics-e84620e6d91e2cbd7aa683846ccb9664ae9137eb.tar.gz
gn: Add python-enlighten.
* gn/packages/python.scm (python-enlighten): New variable.
Diffstat (limited to 'gn/packages/python.scm')
-rw-r--r--gn/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 9ea3c81..da0cdc6 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1889,3 +1889,25 @@ concepts.")
(description "@code{python-addict} provides dictionaries whose items can
be get and set using both attribute and item syntax.")
(license license:expat)))
+
+(define-public python-enlighten
+ (package
+ (name "python-enlighten")
+ (version "1.12.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "enlighten" version))
+ (sha256
+ (base32
+ "0psvglhi0c7d7pdk9rfb8scnv3xbq2fz78619x2mxvz094mxkwvm"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-blessed python-prefixed))
+ (home-page "https://github.com/Rockhopper-Technologies/enlighten")
+ (synopsis "Console progress bar library")
+ (description "@code{python-enlighten} is a console progress bar library
+for Python. The main advantage of Enlighten is that it allows writing to
+stdout and stderr without any redirection or additional code---just print or
+log as you normally would. Enlighten also includes experimental support for
+Jupyter Notebooks.")
+ (license license:mpl2.0)))