aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/python.scm
diff options
context:
space:
mode:
authorjgart2022-04-04 12:47:11 -0400
committerjgart2022-04-04 12:47:11 -0400
commit123a4dc64655f59ebcc64c6c9ece17d81ec63b79 (patch)
tree3d3fad2dff900e4fe830022ffeb5280f1f260aa1 /gn/packages/python.scm
parent98c6f7a191eecd6aa94447e034eaddd691d24336 (diff)
downloadguix-bioinformatics-123a4dc64655f59ebcc64c6c9ece17d81ec63b79.tar.gz
gn: packages: python: add python-supervisor
todo: fix tests: https://github.com/NixOS/nixpkgs/blob/nixos-21.11/pkgs/development/python-modules/supervisor/default.nix#L16
Diffstat (limited to 'gn/packages/python.scm')
-rw-r--r--gn/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index a15edae..3f9a847 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1855,3 +1855,26 @@ file format spec.")
pytest PDB integration.")
(license license:expat))))
+(define-public python-supervisor
+ (package
+ (name "python-supervisor")
+ (version "4.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "supervisor" version))
+ (sha256
+ (base32 "18lpddhyl8ziy6lc0klassxpd8kdg8c0nhkrvz1k3ipfw4n5ip20"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest python-pytest-cov))
+ (arguments (list #:tests? #f)) ; fixme
+ (home-page "http://supervisord.org/")
+ (synopsis "A system for controlling process state under UNIX")
+ (description
+ "This package provides a system for controlling process state under UNIX")
+ (license
+ ;; https://github.com/Supervisor/supervisor/issues/1364
+ (license:fsf-free (string-append "https://web.archive.org/web/20190211105114/"
+ "http://www.repoze.org/LICENSE.txt")))))
+