aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/julia.scm
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi2022-12-06 05:13:26 +0300
committerFrederick Muriuki Muriithi2022-12-06 05:23:55 +0300
commit27adf2acf3c14e09d9c188e476951089180c374a (patch)
treef9a8edf112cf26d4e943ccc1defb5190032e34cf /gn/packages/julia.scm
parentfb631515ccf985e6e89c6cb03a86833aa3b963c6 (diff)
downloadguix-bioinformatics-27adf2acf3c14e09d9c188e476951089180c374a.tar.gz
gn: (julia-visuals): Slurp expressions to fix package definition
* gn/packages/julia.scm (julia-visuals): slurp in sexps to fix the package definition.
Diffstat (limited to 'gn/packages/julia.scm')
-rw-r--r--gn/packages/julia.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gn/packages/julia.scm b/gn/packages/julia.scm
index 3b5def1..03425b2 100644
--- a/gn/packages/julia.scm
+++ b/gn/packages/julia.scm
@@ -31,8 +31,8 @@
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sens/visuals")
- (commit commit)))
+ (url "https://github.com/sens/visuals")
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
(base32 "15hshm5qrig5qbj02xy4ji79kfc72n93nna5nvxkhvb8gw3vvx07"))))
@@ -53,23 +53,23 @@
(let ((out (assoc-ref outputs "out")))
;; Copied from the Dockerfile.
(for-each
- (lambda (file)
- (copy-recursively file (string-append out "/" file)))
- (list "plutoserver"
- "environment.yml"
- "setup.py"
- "runpluto.sh"
- "notebooks"
- "Project.toml"
- "Manifest.toml")))))
+ (lambda (file)
+ (copy-recursively file (string-append out "/" file)))
+ (list "plutoserver"
+ "environment.yml"
+ "setup.py"
+ "runpluto.sh"
+ "notebooks"
+ "Project.toml"
+ "Manifest.toml")))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
;; Do we need to wrap this with PYTHONPATH too?
(wrap-script (string-append out "/runpluto.sh")
- `("PATH" ":" prefix (,(string-append (assoc-ref inputs "julia") "/bin")
- ,(string-append (assoc-ref inputs "coreutils") "/bin")))
- `("JULIA_LOAD_PATH" ":" prefix (,(getenv "JULIA_LOAD_PATH")))))))
+ `("PATH" ":" prefix (,(string-append (assoc-ref inputs "julia") "/bin")
+ ,(string-append (assoc-ref inputs "coreutils") "/bin")))
+ `("JULIA_LOAD_PATH" ":" prefix (,(getenv "JULIA_LOAD_PATH")))))))
(replace 'precompile
(lambda _
(invoke "julia" "-e" "\"import Pkg; Pkg.instantiate(); Pkg.status(); Pkg.precompile()\""))))))
@@ -78,7 +78,7 @@
;; `( ;; from setup.py
;; ("python-jupyter-server-proxy"
;; ,(@ (gn packages python) python-jupyter-server-proxy-1)))
- )
+
(inputs
`(("julia-distributions" ,julia-distributions)
("julia-latexstrings" ,julia-latexstrings)