aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/globus.scm
diff options
context:
space:
mode:
authorArun Isaac2024-02-29 01:14:17 +0000
committerArun Isaac2024-02-29 01:14:17 +0000
commitb8eac8a000f1c2de203281b3c016fe959fcff7a4 (patch)
tree44364fa7983804239d7d4ae9fd00bd2058c720f3 /gn/packages/globus.scm
parentc7641ce85b216bf1b9d337a35de8e9a85228a6f3 (diff)
downloadguix-bioinformatics-b8eac8a000f1c2de203281b3c016fe959fcff7a4.tar.gz
gnu: Add python-click-type-test.
* gn/packages/globus.scm (python-click-type-test): New variable.
Diffstat (limited to 'gn/packages/globus.scm')
-rw-r--r--gn/packages/globus.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gn/packages/globus.scm b/gn/packages/globus.scm
index 43a8f7a..af296f3 100644
--- a/gn/packages/globus.scm
+++ b/gn/packages/globus.scm
@@ -1,4 +1,5 @@
(define-module (gn packages globus)
+ #:use-module (gnu packages check)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -27,3 +28,22 @@
(description "@code{python-globus-sdk} provides a convenient Pythonic interface to
Globus APIs.")
(license license:asl2.0)))
+
+(define-public python-click-type-test
+ (package
+ (name "python-click-type-test")
+ (version "0.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "click-type-test" version))
+ (sha256
+ (base32
+ "1i3z7akiz7s8jy6x0vzrak88m55ac1spq88vziwryzr7355y3hgq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-click))
+ (home-page "https://github.com/sirosen/click-type-test")
+ (synopsis "Test that type annotations match click parameter types")
+ (description "@code{python-click-type-test} allows you to test that your click
+options and arguments match your type annotations.")
+ (license license:expat)))