aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner2022-03-20 08:56:33 +0200
committerEfraim Flashner2022-03-20 08:56:33 +0200
commit7c78efdce60ca3c65a59c28ef806b4904e5ed6b5 (patch)
tree97cb64359eb8f45dcc5307f5054e6acaba02fa5f /gn/packages/bioinformatics.scm
parentb923c80749dce8f78c623b3908618941c5305f03 (diff)
downloadguix-bioinformatics-7c78efdce60ca3c65a59c28ef806b4904e5ed6b5.tar.gz
gn: upstream python-scikit-allel
Diffstat (limited to 'gn/packages/bioinformatics.scm')
-rw-r--r--gn/packages/bioinformatics.scm49
1 files changed, 0 insertions, 49 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 6dde766..01e4c59 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -3137,52 +3137,3 @@ from a VCF. In particular, pixy facilitates the use of VCFs containing
invariant (monomorphic) sites, which are essential for the correct computation
of π and dxy in the face of missing data (i.e. always).")
(license license:expat)))
-
-(define-public python-scikit-allel
- (package
- (name "python-scikit-allel")
- (version "1.3.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "scikit-allel" version))
- (sha256
- (base32 "1vg88ng6gd175gzk39iz1drxig5l91dyx398w2kbw3w8036zv8gj"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "setup.py" "build_ext" "--inplace")
- (invoke "python" "-m" "pytest" "-v" "allel"
- ;; AttributeError: 'Dataset' object has no attribute 'asstr'
- ;; Perhaps need python-h5py@3?
- "-k" (string-append
- "not test_vcf_to_hdf5"
- " and not test_vcf_to_hdf5_exclude"
- " and not test_vcf_to_hdf5_rename"
- " and not test_vcf_to_hdf5_group"
- " and not test_vcf_to_hdf5_ann"))))))))
- (propagated-inputs
- (list python-dask
- python-numpy))
- (native-inputs
- (list python-cython
- ;; The following are all needed for the tests
- htslib
- python-h5py
- python-hmmlearn
- python-numexpr
- python-pytest
- python-scipy
- python-setuptools-scm
- python-zarr))
- (home-page "https://github.com/cggh/scikit-allel")
- (synopsis "Explore and analyze genetic variation data")
- (description
- "This package provides utilities for exploratory analysis of large scale
-genetic variation data.")
- (license license:expat)))