aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner2022-03-31 09:24:11 +0300
committerEfraim Flashner2022-03-31 09:24:11 +0300
commit5946e2eaa8d4db0b94fde58ddf118b8c5e552adf (patch)
treee89acd26a41ce971e01b64342f6ec3a5053474d1 /gn/packages/bioinformatics.scm
parent7cbb463281d2aff8184f8c7689d1cfcb622de51c (diff)
downloadguix-bioinformatics-5946e2eaa8d4db0b94fde58ddf118b8c5e552adf.tar.gz
gn: Update gfaffix to 0.1.3
Diffstat (limited to 'gn/packages/bioinformatics.scm')
-rw-r--r--gn/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 01e4c59..e8df572 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -462,7 +462,7 @@ reads.")
(define-public gfaffix
(package
(name "gfaffix")
- (version "0.1.2.2")
+ (version "0.1.3")
(source
(origin
(method git-fetch)
@@ -471,7 +471,7 @@ reads.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1sh244yyhkaxbd635qjyig0wyxc57h8r1pwvs1vgdvlniw6h2cxy"))
+ (base32 "1biss5qv6ag1dfkn1nspwd528hpzgn8i4jydvbv2z7yv7sc685rh"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -479,8 +479,9 @@ reads.")
(("^handlegraph.*") "handlegraph = \"0.7\"\n"))))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-clap" ,rust-clap-3)
+ `(#:install-source? #f
+ #:cargo-inputs
+ (("rust-clap" ,rust-clap-3.1)
("rust-rustc-hash" ,rust-rustc-hash-1)
("rust-regex" ,rust-regex-1)
("rust-handlegraph" ,rust-handlegraph-0.7)
@@ -495,8 +496,7 @@ reads.")
(let ((handlebar-version ,(package-version rust-handlegraph-0.7)))
(substitute* "Cargo.toml"
(("\"0.7\"")
- (string-append "{ version = \"" handlebar-version "\" }")))
- #t))))))
+ (string-append "{ version = \"" handlebar-version "\" }")))))))))
(home-page "https://github.com/marschall-lab/GFAffix")
(synopsis "Identify walk-preserving shared affixes in variation graphs")
(description