aboutsummaryrefslogtreecommitdiff
path: root/delly-use-system-libraries.patch
diff options
context:
space:
mode:
authorpjotrp2016-03-18 21:25:57 -0500
committerpjotrp2016-03-18 21:25:57 -0500
commite9a4fd0b609d4d1ff6b3a622d4f590d092e6def8 (patch)
treec24b0a2dd7a78919b6ab3a417c3ecfbd5850b5bc /delly-use-system-libraries.patch
parent364d11268ecea6bf31a48a7942b4c599dc386212 (diff)
parent97f4e53b34e818c06f394e5272a51fbce6589d2f (diff)
downloadguix-bioinformatics-e9a4fd0b609d4d1ff6b3a622d4f590d092e6def8.tar.gz
Merge branch 'master' into dennis
Diffstat (limited to 'delly-use-system-libraries.patch')
-rw-r--r--delly-use-system-libraries.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/delly-use-system-libraries.patch b/delly-use-system-libraries.patch
new file mode 100644
index 0000000..3ce817f
--- /dev/null
+++ b/delly-use-system-libraries.patch
@@ -0,0 +1,65 @@
+This patch let's Delly use the system versions of htslib and boost.
+
+Patch by Roel Janssen <roel@gnu.org>
+--- a/Makefile 2016-03-16 13:08:49.936706607 +0100
++++ b/Makefile 2016-03-16 13:09:12.351706212 +0100
+@@ -9,8 +9,8 @@
+
+ # Flags
+ CXX=g++
+-CXXFLAGS += -isystem ${SEQTK_ROOT} -isystem ${BOOST_ROOT} -pedantic -W -Wall -Wno-unknown-pragmas
+-LDFLAGS += -L${SEQTK_ROOT} -L${BOOST_ROOT}/stage/lib -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time
++CXXFLAGS += -pedantic -W -Wall -Wno-unknown-pragmas
++LDFLAGS += -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time
+
+ # Additional flags for release/debug
+ ifeq (${PARALLEL}, 1)
+@@ -23,7 +23,7 @@
+ ifeq (${STATIC}, 1)
+ LDFLAGS += -static -static-libgcc -pthread -lhts -lz
+ else
+- LDFLAGS += -lhts -lz -Wl,-rpath,${SEQTK_ROOT},-rpath,${BOOST_ROOT}/stage/lib
++ LDFLAGS += -lhts -lz
+ endif
+ ifeq (${DEBUG}, 1)
+ CXXFLAGS += -g -O0 -fno-inline -DDEBUG
+@@ -41,32 +41,24 @@
+ DELLYSOURCES = $(wildcard src/*.h) $(wildcard src/*.cpp)
+
+ # Targets
+-TARGETS = .htslib .boost src/delly src/extract src/cov src/iover src/stats
++TARGETS = src/delly src/extract src/cov src/iover src/stats
+
+ all: $(TARGETS)
+
+-.htslib: $(HTSLIBSOURCES)
+- cd src/htslib && make && make lib-static && cd ../../ && touch .htslib
+-
+-.boost: $(BOOSTSOURCES)
+- cd src/modular-boost && ./bootstrap.sh --prefix=${PWD}/src/modular-boost --without-icu --with-libraries=iostreams,filesystem,system,program_options,date_time && ./b2 && ./b2 headers && cd ../../ && touch .boost
+-
+-src/delly: .htslib .boost $(DELLYSOURCES)
++src/delly: $(DELLYSOURCES)
+ $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
+
+-src/extract: .htslib .boost $(DELLYSOURCES)
++src/extract: $(DELLYSOURCES)
+ $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
+
+-src/cov: .htslib .boost $(DELLYSOURCES)
++src/cov: $(DELLYSOURCES)
+ $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
+
+-src/iover: .htslib .boost $(DELLYSOURCES)
++src/iover: $(DELLYSOURCES)
+ $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
+
+-src/stats: .htslib .boost $(DELLYSOURCES)
++src/stats: $(DELLYSOURCES)
+ $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
+
+ clean:
+- cd src/htslib && make clean
+- cd src/modular-boost && ./b2 --clean-all
+- rm -f $(TARGETS) $(TARGETS:=.o) .htslib .boost
++ rm -f $(TARGETS) $(TARGETS:=.o)