aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMunyoki Kilyungi2023-08-08 11:33:48 +0300
committerFrederick Muriuki Muriithi2023-08-08 12:45:30 +0300
commitf423da848d0b9ef47c140516ba349bff7127bea5 (patch)
tree511d143c4f7f4877e0b9b27049abf4e8216fee09 /setup.py
parent48fe74de02eb42d40cf0c8f9ec6f1f5a871208b8 (diff)
downloadgn-auth-f423da848d0b9ef47c140516ba349bff7127bea5.tar.gz
Set the root packages as "gn_auth"
* setup.py: Delete "packages". Add package_dir.
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 31fd889..573adb4 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -31,11 +31,7 @@ setup(author="Frederick M. Muriithi",
long_description=LONG_DESCRIPTION,
long_description_content_type="text/markdown",
name="GeneNetwork-Auth",
- packages=[
- "gn_auth",
- "gn_auth.auth",
- "tests"
- ],
+ package_dir = {'': "gn_auth"},
url="https://github.com/genenetwork/gn-auth",
version="0.0.0",
tests_require=["pytest", "hypothesis"],