aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b8407a4..8bfa288 100755
--- a/setup.py
+++ b/setup.py
@@ -14,18 +14,22 @@ setup(author='Bonface M. K.',
'science and machine learning'),
install_requires=[
"bcrypt>=3.1.7"
+ "click"
"Flask==1.1.2"
"mypy==0.790"
"mypy-extensions==0.4.3"
"mysqlclient==2.0.1"
"numpy==1.20.1"
"pylint==2.5.3"
+ "pymonad"
"redis==3.5.3"
"requests==2.25.1"
"scipy==1.6.0"
"plotly==4.14.3"
"flask-cors==3.0.9"
+ "xapian-bindings"
],
+ scripts=["scripts/index-genenetwork"],
license='GPLV3',
long_description=long_description(),
long_description_content_type='text/markdown',