aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArun Isaac2022-10-18 14:40:47 +0530
committerArun Isaac2022-10-18 17:45:33 +0530
commit06da0390a1de5d0aa8eb6d7a0ed3120e350f8a0b (patch)
tree56d8e05990db51bdeb8b6bc420e021cea842621c /setup.py
parent30b8c86a8bb29451689735ba9cab95c6e104797c (diff)
downloadgenenetwork3-06da0390a1de5d0aa8eb6d7a0ed3120e350f8a0b.tar.gz
Add xapian indexing script.
* scripts/index-genenetwork: New file. * setup.py (install_requires): Add click, pymonad and xapian-bindings. (scripts): Add scripts/index-genenetwork.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b8407a4..8bfa288 100755
--- a/setup.py
+++ b/setup.py
@@ -14,18 +14,22 @@ setup(author='Bonface M. K.',
'science and machine learning'),
install_requires=[
"bcrypt>=3.1.7"
+ "click"
"Flask==1.1.2"
"mypy==0.790"
"mypy-extensions==0.4.3"
"mysqlclient==2.0.1"
"numpy==1.20.1"
"pylint==2.5.3"
+ "pymonad"
"redis==3.5.3"
"requests==2.25.1"
"scipy==1.6.0"
"plotly==4.14.3"
"flask-cors==3.0.9"
+ "xapian-bindings"
],
+ scripts=["scripts/index-genenetwork"],
license='GPLV3',
long_description=long_description(),
long_description_content_type='text/markdown',