aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi2022-02-11 07:59:49 +0300
committerFrederick Muriuki Muriithi2022-02-11 08:08:59 +0300
commit5c5df8148fcaaed33a49a29cd303d739855ea251 (patch)
tree24d95e64d0fa3b0f60cd049248135e5ade785f0f /setup.py
parent651c8ad9ae20ab52e7ab694c0caa9d92774b49b5 (diff)
downloadgenenetwork3-5c5df8148fcaaed33a49a29cd303d739855ea251.tar.gz
Add scaffolding to run different types of tests
Enable running commands: - `python3 setup.py unit_check`: run the unit tests - `python3 setup.py integration_check`: run integration tests - `python3 setup.py performance_check`: run performance tests
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 55b4be2..a4e95d1 100644
--- a/setup.py
+++ b/setup.py
@@ -34,4 +34,9 @@ setup(author='Bonface M. K.',
'tests'
],
url='https://github.com/genenetwork/genenetwork3',
- version='0.1')
+ version='0.1',
+ # ---- TESTING ---- #
+ setup_requires=['pytest-runner'],
+ tests_require=["pytest", "hypothesis"]
+ # ---- END: TESTING ---- #
+ )