aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArun Isaac2023-12-22 11:29:12 +0000
committerArun Isaac2023-12-22 11:29:12 +0000
commit093163ebd511700078f998fa754e786435a81d1b (patch)
treee9d2d3563f42dea7814a8c44c781b4c02d49af1e /setup.py
parente9ec827589ec3666bb2301437c60a54dea7f12e7 (diff)
downloadgenenetwork3-093163ebd511700078f998fa754e786435a81d1b.tar.gz
setup.py: Find packages automatically using find_packages.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 2 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 465c4fc..326aef9 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
"""Basic setup script for gn3"""
-from setuptools import setup # type: ignore
+from setuptools import setup, find_packages # type: ignore
from setup_commands import RunTests
def long_description():
@@ -35,13 +35,7 @@ setup(author='Bonface M. K.',
long_description=long_description(),
long_description_content_type='text/markdown',
name='gn3',
- packages=[
- 'gn3',
- 'gn3.api',
- 'gn3.computations',
- 'gn3.db',
- 'tests'
- ],
+ packages=find_packages(),
url='https://github.com/genenetwork/genenetwork3',
version='0.1',
tests_require=["pytest", "hypothesis"],