aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorpjotrp2016-03-01 08:55:10 +0000
committerPjotr Prins2016-04-20 09:59:30 +0000
commit2fd8e09c3de9ee539e47bdb416a4c0df89ff15ab (patch)
treeb7684c3301343731da989c6a82b4cc51a4f20d68 /setup.py
parent6cf118eb55453d0ca041cf139bae4839ceb0286a (diff)
downloadgenenetwork2-2fd8e09c3de9ee539e47bdb416a4c0df89ff15ab.tar.gz
setup: prepare for Guix runtime
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 1b11acc0..a9b71fab 100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,17 @@
+# Run setup from python - this script is used by the GNU Guix builder.
+
from setuptools import setup, find_packages
setup(name='genenetwork2',
version='2.0',
+ author = "The GeneNetwork Team",
+ author_email='rwilliams@uthsc.edu',
+ url = "https://github.com/genenetwork/genenetwork2/blob/master/README.md",
+ description = 'Website and tools for genetics.',
include_package_data=True,
- # packages=find_packages()
- packages=['wqflask']
- )
+ packages=['wqflask','etc'],
+ scripts=['bin/genenetwork2'],
+ # package_data = {
+ # 'etc': ['*.py']
+ # }
+)