aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bioinformatics.scm35
-rw-r--r--gn/packages/genenetwork.scm36
-rw-r--r--gn/packages/python.scm2
-rw-r--r--gn/packages/statistics.scm28
4 files changed, 64 insertions, 37 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index f62949d..b509fc3 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -772,41 +772,6 @@ to sample traits. Also includes a number of utility functions for
data manipulation and visualization.")
(license license:gpl2+))))
-(define-public qtlreaper
- (package
- (name "qtlreaper")
- (version "1.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/qtlreaper/qtlreaper-" version ".tar.gz"
- ;; "http://downloads.sourceforge.net/project/qtlreaper/qtlreaper/1.1.1/qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb"))
- ))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0rbf030940nbbbkggdq2dxiy3c0jv8l4y3vvyfxhqimgj0qv3l1x"))))
- (build-system python-build-system)
- ;; (native-inputs
- ;; `(("python-setuptools" ,python-setuptools)))
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; no 'setup.py test'
- (home-page "http://qtlreaper.sourceforge.net/")
- (synopsis "Tool for scanning expression data for QTLs")
- (description
- "It is essentially the batch-oriented version of WebQTL. It
-requires, as input, expression data from members of a set of
-recombinant inbred lines and genotype information for the same
-lines. It searches for an association between each expression trait
-and all genotypes and evaluates that association by a permutation
-test. For the permutation test, it performs only as many permutations
-as are necessary to define the empirical P-value to a reasonable
-precision. It also performs bootstrap resampling to estimate the
-confidence region for the location of a putative QTL.")
- (license license:gpl2+)))
-
(define-public plink2
(package
(name "plink2")
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index a7317c6..dfbba02 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -87,6 +87,41 @@
(description #f)
(license #f)))
+(define-public qtlreaper
+ (let ((commit "71fbbe2b35e4f54937be2d54d09fb71d25fe5fad"))
+ (package
+ (name "qtlreaper")
+ (version (string-append "1.1-gn2" (string-take commit 7) ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; (url "https://github.com/genenetwork/genenetwork2.git")
+ (url "https://github.com/pjotrp/QTLreaper.git")
+ (commit commit)))
+ (file-name (string-append name "-" (string-take commit 7)))
+ (sha256
+ (base32
+ "0g0v20lh7773cm2xdqz6xzwjw4130y265n79z5x20p5aja5y5kmg"))))
+ (build-system python-build-system)
+ ;; (native-inputs
+ ;; `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ ))
+ (home-page "http://qtlreaper.sourceforge.net/")
+ (synopsis "Tool for scanning expression data for QTLs")
+ (description
+ "Batch-oriented version of WebQTL. It requires, as input,
+expression data from members of a set of recombinant inbred lines and
+genotype information for the same lines. It searches for an
+association between each expression trait and all genotypes and
+evaluates that association by a permutation test. For the permutation
+test, it performs only as many permutations as are necessary to define
+the empirical P-value to a reasonable precision. It also performs
+bootstrap resampling to estimate the confidence region for the
+location of a putative QTL.")
+ (license license:gpl2+))))
+
(define-public genenetwork1
(let ((commit "d622c803b"))
(package
@@ -157,6 +192,7 @@
(propagated-inputs `( ;; propagated for development purposes
("python" ,python-2) ;; probably superfluous
("r" ,r)
+ ("r-ctl" ,r-ctl)
("r-wgcna" ,r-wgcna)
("r-qtl" ,r-qtl)
("redis" ,redis)
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index e4196cf..7dbd968 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -396,7 +396,7 @@ version ".tgz"))
(native-inputs
`(("python2-setuptools" ,python2-setuptools)))
(propagated-inputs
- `(("python2-pillow" ,python2-pillow)))
+ `(("python2-pil" ,python2-pil)))
(arguments
`(
#:python ,python-2
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index dbe6b99..b83ccf2 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -14,6 +14,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bioinformatics)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpio)
@@ -333,7 +334,7 @@
(uri (git-reference
(url "https://github.com/genenetwork/pylmm.git")
(commit commit)))
- (file-name (string-append name "-" commit))
+ (file-name (string-append name "-" commit))
(sha256
(base32
"0wryaadb36i275p9d2i1kzflahvbl9kj5wlk8jlbvjij8gpqg964"))))
@@ -362,3 +363,28 @@
(description "Fast and lightweight linear mixed-model (LMM) solver
for use in genome-wide association studies (GWAS).")
(license license:agpl3+))))
+
+(define-public r-ctl
+ (package
+ (name "r-ctl")
+ (version "1.0.0-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/ctl_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12hrrql9wz43s1d3sfyzlqzx7ajrl3hvf96776ik6icbm8by8h6j"))))
+ (build-system r-build-system)
+ (inputs `(
+ ("r-qtl" ,r-qtl)
+ ))
+ (home-page "https://github.com/DannyArends/CTLmapping")
+ (synopsis "R package for analysis of genetical genomic data to identify genetic loci associated with correlation changes in quantitative traits (CTL)")
+ (description "Analysis of experimental crosses to identify genetic
+markers associated with correlation changes in quantitative
+traits (CTL). The additional correlation information obtained can be
+combined with QTL information to perform de novo reconstruction of
+interaction networks.")
+ (license license:gpl3)))