aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/bioinformatics.scm36
-rw-r--r--gn/packages/statistics.scm40
2 files changed, 61 insertions, 15 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index b7384ef..896767b 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -10,7 +10,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
- #:use-module (guix build-system ruby)
+ ;; #:use-module (guix build-system ruby)
#:use-module (guix build-system r)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
@@ -26,6 +26,7 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages ldc)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
@@ -34,7 +35,6 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
- #:use-module (gnu packages ruby)
#:use-module (gnu packages statistics)
#:use-module (gnu packages tbb)
#:use-module (gnu packages textutils)
@@ -44,6 +44,7 @@
#:use-module (gnu packages zip)
#:use-module (gnu packages bootstrap)
#:use-module (gn packages python)
+ #:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
(define-public my-deploy
@@ -379,6 +380,7 @@ association studies (GWAS).")
("redis" ,redis)
("mysql" ,mysql)
("gemma" ,gemma-git)
+ ("pylmm-gn2" ,pylmm-gn2)
("plink2" ,plink-ng)
("nginx" ,nginx)
("python2-flask" ,python2-flask)
@@ -457,17 +459,20 @@ internally during various build tasks.")
(license license:boost1.0)))
(define-public sambamba
+ (let ((commit "2ca5a2dba"))
(package
(name "sambamba")
- (version "0.5.9")
+ (version (string-append "0.5.9-" commit))
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/lomereiter/sambamba/archive/v"
- version ".tar.gz"))
- (file-name (string-append "sambamba-" version ".tar.gz"))
- (sha256
- (base32 "152zbg4m10ikr7xgk20c0nwqwrqvydmpc73p2c1fqmbhpk0l0ws6"))))
+ (method git-fetch)
+ (uri (git-reference
+ ;; https://github.com/pjotrp/sambamba.git
+ (url "https://github.com/pjotrp/sambamba.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "1f14wn9aaxwjkmla6pzq3s28741carbr2v0fd2v2mm1dcpwnrqz5"))))
(build-system gnu-build-system)
(inputs
`(("ldc" ,ldc)
@@ -510,16 +515,17 @@ internally during various build tasks.")
;; for Guix, this should be resolved on Sambamba upstream. For
;; now, just extract the source code to the desired directory.
(and (with-directory-excursion "htslib"
- (zero? (system* "tar" "xvf" (assoc-ref inputs "htslib-src")
- "--strip-components=1")))
- (zero? (system* "cp" "-R" (assoc-ref inputs "biod-src") "BioD")))))
+ (zero? (system* "tar" "xvf" (assoc-ref inputs "htslib-src")
+ "--strip-components=1")))
+ (zero? (system* "cp" "-R" (assoc-ref inputs "biod-src") "BioD"))
+ )))
;; Building a production-quality executable is done with a
;; non-default make target. Adding it with #:make-flags breaks
;; building tests. Therefore, the default make got replaced by this.
(replace
'build
(lambda* (#:key (make-flags '()) #:allow-other-keys)
- (zero? (system* "make" "sambamba-ldmd2-64" make-flags)))))))
+ (zero? (system* "make" "-f" "Makefile.guix" make-flags)))))))
(home-page "https://github.com/lomereiter/sambamba")
(synopsis "A tool for working with SAM and BAM files written in D.")
(description
@@ -528,7 +534,7 @@ library), written in the D programming language, for working with SAM
and BAM files. Current parallelised functionality is an important
subset of samtools functionality, including view, index, sort,
markdup, and depth.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public picard
(package
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 065826e..2d83816 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -148,3 +148,43 @@
"R/lmmlite")
(home-page "https://github.com/kbroman/")
(license license:asl2.0)))
+
+(define-public pylmm-gn2
+ (let ((commit "3c6d1cac8"))
+ (package
+ (name "pylmm-gn2")
+ (version (string-append "1.0-" commit ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/genenetwork/pylmm.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "0wryaadb36i275p9d2i1kzflahvbl9kj5wlk8jlbvjij8gpqg964"))))
+ (build-system python-build-system)
+ (inputs `(
+ ("python2-setuptools" ,python2-setuptools)
+ ("python2-scipy" ,python2-scipy)
+ ("python2-numpy" ,python2-numpy)
+ ))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f ; no 'setup.py test'
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'build 'change-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "scripts/pylmm_redis"
+ (("/usr/bin/python") (which "python"))
+ (("\\$PACKAGEDIR") (string-append out "/lib/python2.7/site-packages")))
+ ))))))
+
+ (home-page "http://genenetwork.org/")
+ (synopsis "LMM resolver")
+ (description "Fast and lightweight linear mixed-model (LMM) solver
+for use in genome-wide association studies (GWAS).")
+ (license license:agpl3+))))