aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/genenetwork.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gn/packages/genenetwork.scm')
-rw-r--r--gn/packages/genenetwork.scm91
1 files changed, 90 insertions, 1 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 3051dcb..553fbd7 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -7,6 +7,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -20,6 +21,9 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cran)
+ #:use-module (gn packages crates-io)
+ #:use-module (gnu packages crates-io)
#:use-module (gnu packages databases)
#:use-module (gnu packages cpio)
#:use-module (gn packages elixir)
@@ -53,6 +57,7 @@
#:use-module (gn packages javascript)
#:use-module (gn packages phewas)
#:use-module (gn packages python)
+ #:use-module (gn packages python24)
#:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
@@ -167,6 +172,41 @@ bootstrap resampling to estimate the confidence region for the
location of a putative QTL.")
(license license:gpl2+))))
+(define-public python24-qtlreaper
+ (let ((commit "dd9c7fb2a9d5fa40b4054e1bcb7c57905d98d5f8"))
+ (package
+ (name "python24-qtlreaper")
+ (version (string-append "1.1-gn2-" (string-take commit 7) ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; (url "https://github.com/genenetwork/genenetwork2.git")
+ (url "https://github.com/pjotrp/QTLreaper.git")
+ (commit commit)))
+ (file-name (string-append name "-" (string-take commit 7)))
+ (sha256
+ (base32
+ "1ldcvyk8y8w6f4ci04hzx85sknd5a3h424p5bfi4fz32sm2p7fja"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2.4
+ #:tests? #f)) ; no 'setup.py test' really!
+ (native-inputs
+ `(("python24-setuptools" ,python24-setuptools)))
+ (home-page "http://qtlreaper.sourceforge.net/")
+ (synopsis "Scan expression data for QTLs")
+ (description
+ "Batch-oriented version of WebQTL. It requires, as input,
+expression data from members of a set of recombinant inbred lines and
+genotype information for the same lines. It searches for an
+association between each expression trait and all genotypes and
+evaluates that association by a permutation test. For the permutation
+test, it performs only as many permutations as are necessary to define
+the empirical P-value to a reasonable precision. It also performs
+bootstrap resampling to estimate the confidence region for the
+location of a putative QTL.")
+ (license license:gpl2+))))
+
(define-public python-qtlreaper
(let ((commit "dd9c7fb2a9d5fa40b4054e1bcb7c57905d98d5f8"))
(package
@@ -207,6 +247,55 @@ bootstrap resampling to estimate the confidence region for the
location of a putative QTL.")
(license license:gpl2+))))
+(define-public rust-qtlreaper
+ (let ((commit "eacf6ff1c3d1cd16084a70a7a425bd77080c15de")
+ (revision "1"))
+ (package
+ (name "rust-qtlreaper")
+ (version (git-version "0.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chfi/rust-qtlreaper.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gr2z54i11zz94ra4w06fhfnwnmmhl5xyc8qhlk0v2qq18yfi7ji"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-rand" ,rust-rand-0.6)
+ ("rust-structopt" ,rust-structopt)
+ ("rust-rayon" ,rust-rayon-1.0)
+ ("rust-serde" ,rust-serde)
+ ("rust-serde-json" ,rust-serde-json))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'regenerate-cargo-lock
+ (lambda _
+ (delete-file "Cargo.lock")
+ (invoke "cargo" "generate-lockfile")))
+ (add-after 'patch-generated-file-shebangs 'patch-cargo-checksums
+ (lambda _
+ (use-modules (guix build cargo-utils))
+ (for-each
+ (lambda (filename)
+ (use-modules (guix build cargo-utils))
+ (delete-file filename)
+ (let* ((dir (dirname filename)))
+ (display (string-append
+ "patch-cargo-checksums: generate-checksums for "
+ dir "\n"))
+ (generate-checksums dir)))
+ (find-files "guix-vendor" ".cargo-checksum.json"))
+ #t)))))
+ (home-page "https://github.com/chfi/rust-qtlreaper")
+ (synopsis "Reimplementation of genenetwork/QTLReaper in Rust")
+ (description "Reimplementation of genenetwork/QTLReaper in Rust")
+ (license #f))))
+
(define-public genenetwork2
(let ((commit "1538ffd33af19e6ac922b4ee85fe701408968dfd"))
(package
@@ -247,7 +336,7 @@ location of a putative QTL.")
("python2-pillow" ,python2-pillow)
("python2-cssselect" ,python2-cssselect)
("python2-elasticsearch" ,python2-elasticsearch)
- ("python2-htmlgen-gn" ,python2-htmlgen-gn)
+ ("python2-htmlgen" ,python2-htmlgen)
("python2-jinja2" ,python2-jinja2)
("python2-sqlalchemy" ,python2-sqlalchemy)
("python2-flask-sqlalchemy" ,python2-flask-sqlalchemy)