aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--4store-fix-buildsystem.patch56
-rw-r--r--gn/packages/python.scm2
-rw-r--r--gn/packages/statistics.scm4
3 files changed, 4 insertions, 58 deletions
diff --git a/4store-fix-buildsystem.patch b/4store-fix-buildsystem.patch
deleted file mode 100644
index a72c4d4..0000000
--- a/4store-fix-buildsystem.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-This patch sets a fixed version to avoid needing Git and the .git/ folder.
-It also removes the creation of "/var/lib/4store", which is not available
-during the install phase in GNU Guix.
-
-Patch by Roel Janssen <roel@gnu.org>
-*** 4store-1.1.6-orig/configure.ac Wed Feb 4 19:05:24 2015
---- 4store-1.1.6/configure.ac Wed Mar 23 11:20:38 2016
-***************
-*** 2,13 ****
- # Process this file with autoconf to produce a configure script.
-
- AC_PREREQ([2.50])
-! AC_INIT([4store], m4_esyscmd([./version.sh .version]), [http://4store.org/support/], [4store])
- AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
-! AM_INIT_AUTOMAKE([1.7 std-options -Wall])
- AC_CONFIG_HEADERS(4store-config.h)
-
- # Checks for programs.
- AC_PROG_LIBTOOL
- AC_PROG_AWK
- AC_PROG_CC
---- 2,14 ----
- # Process this file with autoconf to produce a configure script.
-
- AC_PREREQ([2.50])
-! AC_INIT([4store], [1.1.6], [http://4store.org/support/], [4store])
- AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
-! AM_INIT_AUTOMAKE([1.7 std-options foreign -Wall])
- AC_CONFIG_HEADERS(4store-config.h)
-
- # Checks for programs.
-+ AM_PROG_AR
- AC_PROG_LIBTOOL
- AC_PROG_AWK
- AC_PROG_CC
-
-*** 4store-1.1.6-orig/src/utilities/Makefile.am Wed Feb 4 19:05:24 2015
---- 4store-1.1.6/src/utilities/Makefile.am Wed Mar 23 14:05:56 2016
-***************
-*** 13,20 ****
- noinst_PROGRAMS = lex-file-verify 4s-rid
-
- install-data-local:
-! mkdir -p $(DESTDIR)@FS_STORE_ROOT@
-! chmod 1777 $(DESTDIR)@FS_STORE_ROOT@
-
- 4s_backend_destroy_SOURCES = backend-destroy.c
- 4s_backend_destroy_LDADD = ../common/lib4sintl.a
---- 13,19 ----
- noinst_PROGRAMS = lex-file-verify 4s-rid
-
- install-data-local:
-! echo "Please create the following directory: " $(DESTDIR)@FS_STORE_ROOT@
-
- 4s_backend_destroy_SOURCES = backend-destroy.c
- 4s_backend_destroy_LDADD = ../common/lib4sintl.a
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 28f3346..b69dd91 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -60,6 +60,8 @@
(base32
"1ngryr12d3izmhmwplc46xhyj9i7yhrpm90xnsd2578p7m8p5n79"))))
(build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
(home-page
"https://github.com/jamescasbon/PyVCF")
(synopsis
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 06aa1f7..9c619d7 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -319,7 +319,7 @@ for use in genome-wide association studies (GWAS).")
(define-public r-ctl ; guix: ready
(package
(name "r-ctl")
- (version "1.0.0-2")
+ (version "1.0.0-4")
(source
(origin
(method url-fetch)
@@ -327,7 +327,7 @@ for use in genome-wide association studies (GWAS).")
version ".tar.gz"))
(sha256
(base32
- "1gpb43zn411l476dby2g38qkcvh2fsdcvbkr9jb274l1154km1xm"))))
+ "027cij4vdsq3xhi38izzn07q6xwja7n8v95l7kk1pp92y9qkvqv3"))))
(build-system r-build-system)
(inputs `(
("r-qtl" ,r-qtl)