aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gn/packages/genenetwork.scm1
-rw-r--r--gn/packages/lmm.scm24
-rw-r--r--gn/packages/statistics.scm23
3 files changed, 24 insertions, 24 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 9199f00..29915b2 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -107,7 +107,6 @@
(arguments
`(#:python ,python-2
#:tests? #f)) ; no 'setup.py test' really!
-
(home-page "http://qtlreaper.sourceforge.net/")
(synopsis "Scan expression data for QTLs")
(description
diff --git a/gn/packages/lmm.scm b/gn/packages/lmm.scm
index bcb6c47..3761db7 100644
--- a/gn/packages/lmm.scm
+++ b/gn/packages/lmm.scm
@@ -41,6 +41,30 @@
#:use-module (gnu packages bootstrap)
#:use-module (srfi srfi-1))
+
+(define-public r-lmmlite
+ (package
+ (name "r-lmmlite")
+ (version "0.1-9")
+ (source (origin
+ ;; We use the git reference, because there's no CRAN package (yet)
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kbroman/lmmlite.git")
+ (commit "5b833d5")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0v4z4qxa8ki9hlmdwlgslchvg21nqkkq6135nx6w63xikjffxcba"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcppeigen" ,r-rcppeigen)))
+ (synopsis "R/lmmlite")
+ (description
+ "R/lmmlite")
+ (home-page "https://github.com/kbroman/")
+ (license license:asl2.0)))
+
(define-public r-emma ; guix potential candidate (not in CRAN)
(package
(name "r-emma")
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 4af5cc5..af8f8ef 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -301,29 +301,6 @@
"Data and Functions from the book R Graphics, Second Edition. There is a function to produce each figure in the book, plus several functions, classes, and methods defined in Chapter 8.")
(license license:gpl2+)))
-(define-public r-lmmlite
- (package
- (name "r-lmmlite")
- (version "0.1-9")
- (source (origin
- ;; We use the git reference, because there's no CRAN package (yet)
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kbroman/lmmlite.git")
- (commit "5b833d5")))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0v4z4qxa8ki9hlmdwlgslchvg21nqkkq6135nx6w63xikjffxcba"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-rcppeigen" ,r-rcppeigen)))
- (synopsis "R/lmmlite")
- (description
- "R/lmmlite")
- (home-page "https://github.com/kbroman/")
- (license license:asl2.0)))
-
(define-public pylmm-gn2
(let ((commit "3c6d1cac8"))
(package