aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gn/packages/maths.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gn/packages/maths.scm b/gn/packages/maths.scm
index 097000b..d696176 100644
--- a/gn/packages/maths.scm
+++ b/gn/packages/maths.scm
@@ -115,6 +115,9 @@
(lambda _
(substitute* "UFconfig/Makefile"
(("Lib/") ""))
+ ;; octave-3.4.3 expects it to be built with -fPIC
+ (substitute* "UFconfig/UFconfig.mk"
+ (("-O3") "-O3 -fPIC"))
#t))
(add-before 'install 'prepare-directories
(lambda* (#:key outputs #:allow-other-keys)