aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gn/packages/bioinformatics.scm21
-rw-r--r--gn/packages/python.scm73
2 files changed, 87 insertions, 7 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index d4c6e00..fc2c923 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -1226,10 +1226,9 @@ runApp(launch.browser=0, port=4206)~%\n"
"")
(license #f)))
-;; Note this package is incomplete. Needs more to run properly.
(define-public bh20-seq-resource
- (let ((commit "bbca5ac9b2538e410efe3e09651f87e5573145de")
- (revision "2"))
+ (let ((commit "ae4cb3c2cf7103bbc84f52618bb755d7ce25775b")
+ (revision "3"))
(package
(name "bh20-seq-resource")
(version (git-version "1.0" revision commit))
@@ -1240,22 +1239,30 @@ runApp(launch.browser=0, port=4206)~%\n"
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1kkysjgmhp7kfb17470ik821p9djsidyqmkbjvv37jx2w9pvw31z"))))
+ (base32 "1k0gsz4yc8l5znanzd094g2jp40ksbpa9667zr31ayrjx6labz02"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "setup.py"
+ (("py-dateutil") "python-dateutil"))
+ #t))))
(build-system python-build-system)
- (inputs
+ (propagated-inputs
`(("python-arvados-python-client" ,python-arvados-python-client)
+ ("python-dateutil" ,python-dateutil)
("python-flask" ,python-flask)
("python-magic" ,python-magic)
("python-pyyaml" ,python-pyyaml)
("python-pycurl" ,python-pycurl)
("python-pyshex" ,python-pyshex)
+ ("python-ruaml.yaml" ,python38-ruaml.yaml-0.15.76)
("clustalw" ,clustalw)
("python-schema-salad" ,python-schema-salad)))
(native-inputs
`(("git" ,(@ (gnu packages version-control) git))
("python-oauth2client" ,python-oauth2client)
- ("python-pytest" ,python-pytest)
- ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest-4)
+ ("python-pytest-runner" ,python-pytest-runner-2)
("python-uritemplate" ,python-uritemplate)))
(home-page "https://github.com/arvados/bh20-seq-resource")
(synopsis
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 51efc4a..b181767 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -1588,3 +1588,76 @@ handles recursion and lists.")
(synopsis "SPARQL Slurper for rdflib")
(description "This package provides a SPARQL Slurper for rdflib.")
(license license:asl2.0)))
+
+(define-public python38-ruaml.yaml-0.15.76
+ (package
+ (inherit python-ruamel.yaml)
+ (name "python-ruamel.yaml")
+ (version "0.15.76")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruamel.yaml" "0.15.78"))
+ (sha256
+ (base32
+ "0pwxgrma6k47kvsphqz5yrhwnfrhwsrhn6sjp8p21s91wdgkqyc5"))))
+ (arguments
+ `(#:tests? #f ; suprise test failures
+ #:phases
+ (modify-phases %standard-phases
+ ;; For some unknown reason we need: ruamel.yaml<=0.15.77,>=0.15.54
+ ;; But 0.15.78 is the first which builds with python-3.8.
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "__init__.py"
+ (("0\\.15\\.78") "0.15.76")
+ (("15, 78") "15, 76"))
+ #t)))))))
+
+(define-public python2-ruamel.ordereddict
+ (package
+ (name "python2-ruamel.ordereddict")
+ (version "0.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruamel.ordereddict" version))
+ (sha256
+ (base32
+ "0jldrcanmz0284r2y6kbi82vslkaf5hf5q90v7rqxcdjdv952418"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (if tests?
+ (begin (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test/testordereddict.py"))
+ #t))))))
+ (home-page "https://sourceforge.net/projects/ruamel-ordereddict/")
+ (synopsis "Version of dict that keeps keys in insertion resp. sorted order")
+ (description
+ "This package provides a version of dict that keeps keys in insertion resp.
+sorted order.")
+ (license license:expat)))
+
+(define-public python-pytest-4
+ (package
+ (inherit python-pytest)
+ (version "4.6.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32
+ "0ls3pqr86xgif6bphsb6wrww9r2vc7p7a2naq8zcq8115wwq5yjh"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-pytest)
+ ((#:tests? _ #f) #f)))
+ (native-inputs
+ `(("python-argcomplete" ,python-argcomplete)
+ ("python-requests" ,python-requests)
+ ,@(package-native-inputs python-pytest)))))