aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md13
-rw-r--r--gn/packages/bioinformatics.scm51
-rw-r--r--gn/packages/python.scm28
3 files changed, 89 insertions, 3 deletions
diff --git a/README.md b/README.md
index c83f65e..6d8bd0e 100644
--- a/README.md
+++ b/README.md
@@ -30,7 +30,6 @@ Install slurm with
~/.guix-profile/sbin/slurmd -C -D
ClusterName=(null) NodeName=selinunte CPUs=4 Boards=1 SocketsPerBoard=1 CoresPerSocket=2 ThreadsPerCore=2 RealMemory=7890 TmpDisk=29909
-
## Module system
Install the module envirmonment with
@@ -43,6 +42,14 @@ Install the module envirmonment with
VERSION=3.2.10
DATE=2012-12-21
+## python2-numarray 1.5.2
+
+Install the module envirmonment with
+
+ git clone https://github.com/genenetwork/guix-bioinformatics.git
+ export GUIX_PACKAGE_PATH=$PWD/guix-bioinformatics/
+ guix package -i python2-numarray
+
## Common Workflow Language (CWL)
Install the common workflow language tool cwltool with
@@ -54,12 +61,12 @@ Install the common workflow language tool cwltool with
cwtool --version
1.0.20150916041152
+# Packages moved from here to main line GNU Guix
+
## LLVM D compiler
The LLVM D compiler was added to GNU Guix main stream!
-Install with
-
guix package -i ldc
## R/qtl
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index c24eb61..61ab0a1 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -22,6 +22,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages cpio)
#:use-module (gnu packages file)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages machine-learning)
@@ -156,6 +157,56 @@ confidence region for the location of a putative QTL.")
(license license:gpl2)))
+(define-public genenetwork1
+ (let ((commit "d622c803b"))
+ (package
+ (name "genenetwork1")
+ (version (string-append "1.0-" commit ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pjotrp/genenetwork.git")
+ ;; (url "https://github.com/pjotrp/genenetwork.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "09hvy9mf4dnmkb8qg49viffzrxk53m2kr4r955m84dxaa5pdrjha"))))
+ (propagated-inputs `(
+ ("python" ,python-2) ;; probably superfluous
+ ("r" ,r)
+ ))
+ (inputs `(
+ ;; graphviz-2.22.2 htmlgen json numarray-1.5.2 piddle PIL pp-1.5.7 pyx pyXLWriter svg
+ ("mysql" ,mysql)
+ ("nginx" ,nginx)
+ ("graphviz" ,graphviz)
+ ; ("python2-jinja2" ,python2-jinja2)
+ ; ("python2-sqlalchemy" ,python2-sqlalchemy)
+ ; ("python2-setuptools" ,python2-setuptools)
+ ; ("python2-scipy" ,python2-scipy)
+ ;; looks like python-numarray is not needed
+ ; ("python2-numpy" ,python2-numpy)
+ ; ("python2-pandas" ,python2-pandas)
+ ; ("python2-passlib" ,python2-passlib)
+ ; ("python2-redis" ,python2-redis)
+ ; ("python2-requests" ,python2-requests)
+ ; ("python2-simplejson" ,python2-simplejson)
+ ; ("python2-pyyaml" ,python2-pyyaml)
+ ;; python-yolk is not needed
+ ("python2-pil" ,python2-pil)
+ ("plink" ,plink) ;; gn1
+ ; ("r-qtl" ,r-qtl)
+ ))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no 'setup.py test'
+ (home-page "http://genenetwork.org/")
+ (synopsis "Full genenetwork services")
+ (description "Genenetwork installation sumo.")
+ (license license:agpl3+))))
+
(define-public genenetwork2
(let ((commit "9e9475053"))
(package
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 7829932..8f53d54 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -175,3 +175,31 @@ powerful language for representing information.")
(define-public python2-shellescape
(package-with-python2 python-shellescape))
+
+(define-public python2-numarray
+ (package
+ (name "python2-numarray")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ ;; http://sourceforge.net/projects/numpy/files/Old%20Numarray/1.5.2/numarray-1.5.2.tar.gz/download
+ "mirror://sourceforge/numpy/numarray-" version ".tar.gz"
+ ))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x1i4j7yni7k4p9kjxs1lgln1psdmyrz65wp2yr35yn292iw2vbg"))))
+ (build-system python-build-system)
+ ;; (native-inputs
+ ;; `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no 'setup.py test' really!
+ (home-page "http://www.numpy.org/")
+ (synopsis "Numerical library array processing of numbers, strings, records and objects")
+ (description
+ "Numarray is an array processing package designed to efficiently manipulate large multi-dimensional arrays. Numarray is modelled after Numeric and features c-code generated from python template scripts, the capacity to operate directly on arrays in files, and improved type promotions. Numarray provides support for manipulating arrays consisting of numbers, strings, records, or objects using the same basic infrastructure and syntax. Numarray is now part of the
+numpy package, though some legacy software still uses the older versions.")
+ (license license:gpl2))) ; actualy PyRAF http://www.stsci.edu/resources/software_hardware/pyraf/LICENSE