aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorEfraim Flashner2019-10-10 04:25:05 -0500
committerEfraim Flashner2019-10-10 04:25:05 -0500
commit27c79d5c3cb32d4734853defa44a7b3f83e8d53e (patch)
tree010c62a36690d7bc11aa103e7591a5270b3b6e0f /gn
parent98ac34265936e5bf4ecb371bee11d82069e3b853 (diff)
parentcb55444671fd2334a606d360773b339ef6a2a6fe (diff)
downloadguix-bioinformatics-27c79d5c3cb32d4734853defa44a7b3f83e8d53e.tar.gz
Merge remote-tracking branch 'origin/core-updates'
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bnw.scm3
-rw-r--r--gn/packages/genenetwork.scm12
-rw-r--r--gn/packages/python24.scm34
3 files changed, 44 insertions, 5 deletions
diff --git a/gn/packages/bnw.scm b/gn/packages/bnw.scm
index 7b6662c..db30a84 100644
--- a/gn/packages/bnw.scm
+++ b/gn/packages/bnw.scm
@@ -3,6 +3,7 @@
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages gcc)
#:use-module (gn packages graphviz)
#:use-module (gn packages javascript)
#:use-module (gn packages maths)
@@ -124,6 +125,8 @@
("filesaver" ,javascript-filesaver)
("cyto-dagre" ,javascript-cytoscape-dagre)
("panzoom" ,javascript-cytoscape-panzoom)))
+ (native-inputs
+ `(("gcc" ,gcc-5)))
(home-page "http://compbio.uthsc.edu/BNW/")
(synopsis "Bayesian Network Webserver")
(description "This contains the code for the @dfn{Bayesian Network Webserver} (BNW).")
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 7e5a04e..b9ebcc4 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -206,7 +206,17 @@ location of a putative QTL.")
("rust-rayon" ,rust-rayon-1.0)
("rust-serde" ,rust-serde)
("rust-serde-json" ,rust-serde-json)
- ("rust-ndarray" ,rust-ndarray))))
+ ("rust-ndarray" ,rust-ndarray))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-test-data
+ (lambda _
+ (substitute* "src/geneobject.rs"
+ ;; array![Genotype::Unk, Genotype::Unk, Genotype::Pat]
+ (("0.3421367343627405") "0.3421367343627406")
+ ;; array![Genotype::Unk, Genotype::Unk, Genotype::Unk]
+ (("-0.3223330030526561") "-0.32233300305265566"))
+ #t)))))
(home-page "https://github.com/chfi/rust-qtlreaper")
(synopsis "Reimplementation of genenetwork/QTLReaper in Rust")
(description "Reimplementation of genenetwork/QTLReaper in Rust")
diff --git a/gn/packages/python24.scm b/gn/packages/python24.scm
index 1b38d0f..889977d 100644
--- a/gn/packages/python24.scm
+++ b/gn/packages/python24.scm
@@ -11,9 +11,11 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages image)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages tls)
#:use-module (srfi srfi-1))
;; TODO: Check against 'guix lint -c cve python2.4' list:
@@ -45,6 +47,8 @@
(tk (assoc-ref inputs "tk"))
(gdbm (assoc-ref inputs "gdbm"))
(read (assoc-ref inputs "readline"))
+ (rpc (assoc-ref inputs "libtirpc"))
+ (nsl (assoc-ref inputs "libnsl"))
(ssl (assoc-ref inputs "openssl")))
(with-output-to-file "Modules/Setup.local"
(lambda _
@@ -52,15 +56,31 @@
_ssl _ssl.c -DUSE_SSL -I$~a/include/openssl -L~a/lib -lssl -lcrypto~@
_tkinter _tkinter.c tkappinit.c -DWITH_APPINIT -L~a/lib -I~a/include -L~a/lib -I~a/include -ltk~a -ltcl~a~@
gdbm gdbmmodule.c -I~a/include -L~a/lib -lgdbm~@
+ nis nismodule.c -I~a/include/tirpc -I~a/include -ltirpc -lnsl~@
zlib zlibmodule.c -I~a/include -L~a/lib -lz~%"
-read read ssl ssl tcl tcl tk tk ,(version-major+minor (package-version tcl)) ,(version-major+minor (package-version tcl)) gdbm gdbm zlib zlib))))
+read read ssl ssl tcl tcl tk tk ,(version-major+minor (package-version tcl)) ,(version-major+minor (package-version tcl)) gdbm gdbm rpc nsl zlib zlib))))
+ #t))
+ (add-after 'unpack 'patch-rpc-location
+ (lambda _
+ (substitute* "Modules/nismodule.c"
+ (("<rpc/") "<tirpc/rpc/"))
+ (substitute* "setup.py"
+ (("\\['nsl'") "['nsl', 'tirpc'"))
+ #t))
+ (add-after 'unpack 'skip-crypt-module
+ (lambda _
+ (substitute* "setup.py"
+ ((".*cryptmodule.c.*") "\n"))
#t))
(add-before 'check 'delete-failing-tests
(lambda _
(for-each
(lambda (file)
(delete-file (string-append "Lib/test/" file)))
- '("test_socket.py" "test_anydbm.py" "test_whichdb.py" "test_zlib.py"))
+ '("test_socket.py" "test_anydbm.py" "test_whichdb.py"
+ "test_zlib.py" "test_array.py" "test_decimal.py"
+ "test_getargs2.py" "test_long.py" "test_math.py"
+ "test_random.py" "test_str.py" "test_userstring.py"))
#t))
(add-after 'check 'find-netinet-in-h
(lambda* (#:key inputs #:allow-other-keys)
@@ -69,12 +89,18 @@ read read ssl ssl tcl tcl tk tk ,(version-major+minor (package-version tcl)) ,(v
(("/usr/include/netinet/in.h")
(string-append glibc "/include/netinet/in.h")))
#t)))
- (delete 'move-tk-inter)))))
+ (delete 'move-tk-inter)))
+ ;; Python-2.4 does not support '-j'.
+ ((#:make-flags _) ''())))
(native-search-paths
(list (search-path-specification
(variable "PYTHONPATH")
(files '("lib/python2.4/site-packages")))))
- (properties '((cpe-name . "python")))))
+ (inputs
+ `(("libnsl" ,libnsl)
+ ("libtirpc" ,libtirpc)
+ ("openssl" ,openssl-1.0)
+ ,@(alist-delete "openssl" (package-inputs python-2))))))
(define (default-python2.4)
"Return the default Python-2.4 package."