aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorpjotrp2017-02-26 19:13:31 +0000
committerpjotrp2017-02-26 19:13:31 +0000
commit7affda5295cb6bab9cd336be0fea70e1c2bf24d2 (patch)
tree8484a497a32d8d4919c44b64daef0e5f7585c279 /gn
parent699b05703c743baf51f720db22eb0a2438cb8cad (diff)
downloadguix-bioinformatics-7affda5295cb6bab9cd336be0fea70e1c2bf24d2.tar.gz
Added comments on guix viability
- removed r-wcna and r-preprocesscore as they are in Guix now
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/4store.scm2
-rw-r--r--gn/packages/bioinformatics.scm84
-rw-r--r--gn/packages/cwl.scm2
-rw-r--r--gn/packages/genenetwork.scm4
-rw-r--r--gn/packages/glfw.scm2
-rw-r--r--gn/packages/gtest.scm2
-rw-r--r--gn/packages/hyphy.scm2
-rw-r--r--gn/packages/ldc.scm4
-rw-r--r--gn/packages/mongodb.scm2
-rw-r--r--gn/packages/perl.scm2
-rw-r--r--gn/packages/python.scm26
-rw-r--r--gn/packages/ruby.scm6
12 files changed, 33 insertions, 105 deletions
diff --git a/gn/packages/4store.scm b/gn/packages/4store.scm
index 41e3249..ec09112 100644
--- a/gn/packages/4store.scm
+++ b/gn/packages/4store.scm
@@ -39,7 +39,7 @@
#:use-module (gnu packages file)
#:use-module (gnu packages xml))
-(define-public 4store
+(define-public 4store ; guix ready
(let ((commit "c5a56d7c7504551a1f2fff6c16c4d9a440e4a317"))
(package
(name "4store")
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 6be95dc..efb9470 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -397,7 +397,7 @@ combinatorial configurations.\" G Ehrlich - Journal of the ACM (JACM),
replacement for strverscmp.")
(license license:gpl3+))))
-(define-public fastahack
+(define-public fastahack ; guix ready
(let ((commit "c68cebb4f2e5d5d2b70cf08fbdf1944e9ab2c2dd"))
(package
(name "fastahack")
@@ -430,7 +430,7 @@ automatically handles index file generation and use.")
;; A part of the program is licensed GPLv2.
(license (list license:non-copyleft license:gpl2)))))
-(define-public vcflib
+(define-public vcflib ; guix duplicat, see below?
(let ((commit "3ce827d8ebf89bb3bdc097ee0fe7f46f9f30d5fb"))
(package
(name "vcflib")
@@ -523,7 +523,7 @@ format, and a collection of command-line utilities for executing complex
manipulations on VCF files.")
(license license:expat))))
-(define-public bash-tap
+(define-public bash-tap ; guix license issue
(package
(name "bash-tap")
(version "1.0.2")
@@ -565,7 +565,7 @@ in-process output capturing.")
;; The author didn't specify a license.
(license license:public-domain)))
-(define-public freebayes
+(define-public freebayes ; guix dependent package issues
(let ((commit "3ce827d8ebf89bb3bdc097ee0fe7f46f9f30d5fb")
(revision "1"))
(package
@@ -701,78 +701,6 @@ complex events (composite insertion and substitution events) smaller than the
length of a short-read sequencing alignment.")
(license license:expat))))
-(define-public r-biocpreprocesscore
- (package
- (name "r-biocpreprocesscore")
- (version "1.34.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "preprocessCore" version))
- (sha256
- (base32
- "0bcfi26ahs4ybagvz29vlp1wldhhbwwh73xz6v6xb07nakyzb6cf"))))
- (properties
- `((upstream-name . "BiocpreprocessCore")
- (r-repository . bioconductor)))
- (build-system r-build-system)
- (home-page "http://bioconductor.org/packages/preprocessCore")
- (synopsis "Preprocess functions for Bioconductor")
- (description
- "A library of core preprocessing routines.")
- (license license:lgpl2.0+)))
-
-(define-public r-wgcna
- (let ((commit "425bc170cc0873ddbd414675ac40f6d4d724c7cb"))
-(package
- (name "r-wgcna")
- (version (string-append "1.49-" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- ;; (url "https://github.com/genenetwork/WGCNA.git")
- (url "https://github.com/pjotrp/WGCNA.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "1zqnsb8s3065rq1y2y3l79zi8wmdwjkcjls96ypycrb7pmdil58j"))))
- (properties `((upstream-name . "WGCNA")))
- (build-system r-build-system)
- (propagated-inputs
- `( ;; ("r-annotationdbi" ,r-annotationdbi)
- ; ("r-biocparallel" ,r-biocparallel)
- ("r-doparallel" ,r-doparallel)
- ("r-dynamictreecut" ,r-dynamictreecut)
- ("r-fastcluster" ,r-fastcluster)
- ("r-foreach" ,r-foreach)
- ("r-go-db" ,r-go-db)
- ; ("r-grdevices" ,r-grdevices)
- ("r-hmisc" ,r-hmisc)
- ("r-impute" ,r-impute)
- ("r-matrixstats" ,r-matrixstats)
- ; ("r-parallel" ,r-parallel)
- ("r-biocpreprocesscore" ,r-biocpreprocesscore)
- ; ("r-splines" ,r-splines)
- ; ("r-stats" ,r-stats)
- ; ("r-survival" ,r-survival)
- ; ("r-utils" ,r-utils)
- ))
- (arguments
- `(
- #:tests? #f)) ; no 'setup.py test'
- (home-page
- "http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/Rpackages/WGCNA/")
- (synopsis
- "Weighted gene correlation network analysis (wgcna)")
- (description
- "Functions necessary to perform Weighted Correlation Network
-Analysis on high-dimensional data. Includes functions for rudimentary
-data cleaning, construction of correlation networks, module
-identification, summarization, and relating of variables and modules
-to sample traits. Also includes a number of utility functions for
-data manipulation and visualization.")
- (license license:gpl2+))))
-
(define-public plink2
(package
(name "plink2")
@@ -879,7 +807,7 @@ integration with gPLINK and Haploview, there is some support for the
subsequent visualization, annotation and storage of results.")
(license license:gpl3+))))
-(define-public gemma-git
+(define-public gemma-git ; guix candidate
(let ((commit "2de4bfab3"))
(package
(name "gemma-git")
@@ -921,7 +849,7 @@ mixed model and some of its close relatives for genome-wide
association studies (GWAS).")
(license license:gpl3))))
-(define-public vcflib
+(define-public vcflib ; duplicate? See above
(let ((commit "3ce827d8ebf89bb3bdc097ee0fe7f46f9f30d5fb"))
(package
(name "vcflib")
diff --git a/gn/packages/cwl.scm b/gn/packages/cwl.scm
index 8c41187..2acac7c 100644
--- a/gn/packages/cwl.scm
+++ b/gn/packages/cwl.scm
@@ -15,7 +15,7 @@
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1))
-(define-public python-cwltool
+(define-public python-cwltool ; guix: needs work
(package
(name "python-cwltool")
(version "1.0.20150916041152")
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index dfbba02..7ee798e 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -87,7 +87,7 @@
(description #f)
(license #f)))
-(define-public qtlreaper
+(define-public qtlreaper ; guix obsolete - but used in GN2
(let ((commit "71fbbe2b35e4f54937be2d54d09fb71d25fe5fad"))
(package
(name "qtlreaper")
@@ -122,7 +122,7 @@ bootstrap resampling to estimate the confidence region for the
location of a putative QTL.")
(license license:gpl2+))))
-(define-public genenetwork1
+(define-public genenetwork1 ; guix incomplete
(let ((commit "d622c803b"))
(package
(name "genenetwork1")
diff --git a/gn/packages/glfw.scm b/gn/packages/glfw.scm
index 30342f0..6eb3a75 100644
--- a/gn/packages/glfw.scm
+++ b/gn/packages/glfw.scm
@@ -42,7 +42,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages linux))
-(define-public glfw
+(define-public glfw ; guix opengl
(package
(name "glfw")
(version "3.1.2")
diff --git a/gn/packages/gtest.scm b/gn/packages/gtest.scm
index f8b34e9..708df09 100644
--- a/gn/packages/gtest.scm
+++ b/gn/packages/gtest.scm
@@ -49,7 +49,7 @@
#:use-module (gnu packages zip)
#:use-module (gnu packages linux))
-(define-public gtest
+(define-public gtest ; guix check
(let ((revision "1")
(commit "13206d6f53aaff844f2d3595a01ac83a29e383db"))
(package
diff --git a/gn/packages/hyphy.scm b/gn/packages/hyphy.scm
index fea73a4..e5c120a 100644
--- a/gn/packages/hyphy.scm
+++ b/gn/packages/hyphy.scm
@@ -42,7 +42,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages linux))
-(define-public hyphy
+(define-public hyphy ; guix: check
(package
(name "hyphy")
(version "2.2.6")
diff --git a/gn/packages/ldc.scm b/gn/packages/ldc.scm
index 438cfd3..e39d746 100644
--- a/gn/packages/ldc.scm
+++ b/gn/packages/ldc.scm
@@ -33,7 +33,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages zip))
-(define-public ldc-0.17.2
+(define-public ldc-0.17.2 ; guix in main line
(package
(inherit ldcmain:ldc)
(name "ldc")
@@ -116,7 +116,7 @@
(base32
"0n7gvalxwfmia4gag53r9qhcnk2cqrw3n4icj1yri0zkgc27pm60"))))))))
-(define-public ldc-1.1.0-patched
+(define-public ldc-1.1.0-patched ; guix in main line w.o. patch
(let ((version2 "1.1.0")) ; version for libraries
(package
(inherit ldcmain:ldc)
diff --git a/gn/packages/mongodb.scm b/gn/packages/mongodb.scm
index cc4196e..79c2b75 100644
--- a/gn/packages/mongodb.scm
+++ b/gn/packages/mongodb.scm
@@ -27,7 +27,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python))
-(define-public mongodb
+(define-public mongodb ; guix fix tests and maybe non-free
(package
(name "mongodb")
(version "3.3.3")
diff --git a/gn/packages/perl.scm b/gn/packages/perl.scm
index 75256fe..c1b7946 100644
--- a/gn/packages/perl.scm
+++ b/gn/packages/perl.scm
@@ -39,7 +39,7 @@
#:use-module (gnu packages web)
#:use-module (guix build-system perl))
-(define-public perl-time-parsedate
+(define-public perl-time-parsedate ; guix: old lib and tests failing - works though
(package
(name "perl-time-parsedate")
(version "2015.103")
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index fedc2ed..393de4c 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -42,7 +42,7 @@
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1))
-(define-public speedtest-cli
+(define-public speedtest-cli ; guix submitted
(package
(name "speedtest-cli")
(version "1.0.2")
@@ -63,7 +63,7 @@
"Command line interface for testing internet bandwidth using speedtest.net")
(license license:asl2.0)))
-(define-public python-flask-sqlalchemy
+(define-public python-flask-sqlalchemy-in-mainline ; guix main line
(package
(name "python-flask-sqlalchemy")
(version "2.1")
@@ -88,10 +88,10 @@
"Adds SQLAlchemy support to your Flask application")
(license license:bsd-3)))
-(define-public python2-flask-sqlalchemy
+(define-public python2-flask-sqlalchemy ; guix?
(package-with-python2 python-flask-sqlalchemy))
-(define-public python-xlsxwriter
+(define-public python-xlsxwriter ; guix ready
(package
(name "python-xlsxwriter")
(version "0.8.4")
@@ -116,7 +116,7 @@
(define-public python2-xlsxwriter
(package-with-python2 python-xlsxwriter))
-(define-public python-rdflib-jsonld
+(define-public python-rdflib-jsonld ; guix ready
(package
(name "python-rdflib-jsonld")
(version "0.3")
@@ -195,7 +195,7 @@ powerful language for representing information.")
`(#:python ,python-2
#:tests? #f))))) ; 3 tests fail, also outside Guix
-(define-public python-avro
+(define-public python-avro ; guix ready - used by CWL
(package
(name "python-avro")
(version "1.7.7")
@@ -222,7 +222,7 @@ powerful language for representing information.")
(define-public python2-avro
(package-with-python2 python-avro))
-(define-public python-shellescape
+(define-public python-shellescape ; guix ready
(package
(name "python-shellescape")
(version "3.4.1")
@@ -251,7 +251,7 @@ powerful language for representing information.")
(define-public python2-shellescape
(package-with-python2 python-shellescape))
-(define-public python-mysqlclient
+(define-public python-mysqlclient ; guix ready
(package
(name "python-mysqlclient")
(version "1.3.7")
@@ -284,7 +284,7 @@ powerful language for representing information.")
(package-with-python2 python-mysqlclient))
-(define-public python2-htmlgen-gn
+(define-public python2-htmlgen-gn ; guix obsolete
(package
(name "python2-htmlgen-gn")
(version "2.2.2")
@@ -339,7 +339,7 @@ project)")
(description #f)
(license #f)))
-(define-public python2-pil
+(define-public python2-pil ; guix obsolete
(package
(name "python2-pil")
(version "1.1.6")
@@ -400,7 +400,7 @@ capabilities to the Python interpreter.")
"file://README"
"See 'README' in the distribution."))))
-(define-public python2-piddle-gn
+(define-public python2-piddle-gn ; guix obsolete
(package
(name "python2-piddle")
(version "1.0.15-gn")
@@ -428,7 +428,7 @@ version ".tgz"))
(description #f)
(license #f)))
-(define-public python2-parallel
+(define-public python2-parallel ; guix fix number of things
(package
(name "python2-parallel")
(version "1.6.4")
@@ -456,7 +456,7 @@ version ".tgz"))
(description #f)
(license #f)))
-(define-public python2-numarray
+(define-public python2-numarray ; guix: obsolete lib
(package
(name "python2-numarray")
(version "1.5.2")
diff --git a/gn/packages/ruby.scm b/gn/packages/ruby.scm
index 41743d9..5307e1c 100644
--- a/gn/packages/ruby.scm
+++ b/gn/packages/ruby.scm
@@ -96,7 +96,7 @@ a focus on simplicity and productivity.")
(home-page "https://ruby-lang.org")
(license license:ruby)))
-(define-public bio-vcf
+(define-public bio-vcf ; guix ready with tests
(package
(name "bio-vcf")
(version "0.9.2")
@@ -121,7 +121,7 @@ filtering and output rewriting (JSON, RDF etc.)")
"http://github.com/pjotrp/bioruby-vcf")
(license expat)))
-(define-public bio-table
+(define-public bio-table ; guix ready with tests
(package
(name "bio-table")
(version "1.0.0")
@@ -228,7 +228,7 @@ for an example.")
(home-page "https://github.com/knu/webrobots")
(license #f)))
-(define-public ruby-mechanize
+(define-public ruby-mechanize ; guix maybe ready
(package
(name "ruby-mechanize")
(version "2.7.5")