aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorpjotrp2017-03-04 18:08:12 +0000
committerpjotrp2017-03-04 18:08:12 +0000
commit6af7327b699bc4c4b99d489347f90da1dbf13280 (patch)
treedb1b24f9f73bca0ddfe0eae1c93ebeffce33a22f /gn
parentb97bdfd99a5999cbbc08578e6587332d5d7f31f8 (diff)
downloadguix-bioinformatics-6af7327b699bc4c4b99d489347f90da1dbf13280.tar.gz
genenetwork: adding phewas
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/genenetwork.scm4
-rw-r--r--gn/packages/python.scm2
2 files changed, 5 insertions, 1 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 7ee798e..73fb3b8 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages zip)
#:use-module (gnu packages bootstrap)
#:use-module (gn packages bioinformatics)
+ #:use-module (gn packages phewas)
#:use-module (gn packages python)
#:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
@@ -193,8 +194,9 @@ location of a putative QTL.")
("python" ,python-2) ;; probably superfluous
("r" ,r)
("r-ctl" ,r-ctl)
- ("r-wgcna" ,r-wgcna)
+ ("r-phewas" ,r-phewas)
("r-qtl" ,r-qtl)
+ ("r-wgcna" ,r-wgcna)
("redis" ,redis)
("mysql" ,mysql)
("gemma" ,gemma-git)
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 393de4c..3158dd2 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -471,6 +471,8 @@ version ".tgz"))
(base32
"0x1i4j7yni7k4p9kjxs1lgln1psdmyrz65wp2yr35yn292iw2vbg"))))
(build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
(arguments
`(#:python ,python-2
#:tests? #f)) ; no 'setup.py test' really!