aboutsummaryrefslogtreecommitdiff
path: root/gn
diff options
context:
space:
mode:
authorpjotrp2016-02-21 07:53:38 +0000
committerpjotrp2016-02-21 07:53:38 +0000
commit8511f455487b949109f8afd701c6becbf43553e7 (patch)
treecd1374ff622d624dd0788cecd63eccb279fc595b /gn
parenteb3d652afc40645db643a0b8df8a9598338ffea0 (diff)
parentdfb685956526dce67a8e03849bffd1d9d52c5958 (diff)
downloadguix-bioinformatics-8511f455487b949109f8afd701c6becbf43553e7.tar.gz
Merge branch 'gn2'
Diffstat (limited to 'gn')
-rw-r--r--gn/packages/bioinformatics.scm2
-rw-r--r--gn/packages/statistics.scm40
2 files changed, 42 insertions, 0 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 0c4436c..75b9de7 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages zip)
#:use-module (gnu packages bootstrap)
#:use-module (gn packages python)
+ #:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
(define-public my-deploy
@@ -379,6 +380,7 @@ association studies (GWAS).")
("redis" ,redis)
("mysql" ,mysql)
("gemma" ,gemma-git)
+ ("pylmm-gn2" ,pylmm-gn2)
("plink2" ,plink-ng)
("nginx" ,nginx)
("python2-flask" ,python2-flask)
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 065826e..2d83816 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -148,3 +148,43 @@
"R/lmmlite")
(home-page "https://github.com/kbroman/")
(license license:asl2.0)))
+
+(define-public pylmm-gn2
+ (let ((commit "3c6d1cac8"))
+ (package
+ (name "pylmm-gn2")
+ (version (string-append "1.0-" commit ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/genenetwork/pylmm.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "0wryaadb36i275p9d2i1kzflahvbl9kj5wlk8jlbvjij8gpqg964"))))
+ (build-system python-build-system)
+ (inputs `(
+ ("python2-setuptools" ,python2-setuptools)
+ ("python2-scipy" ,python2-scipy)
+ ("python2-numpy" ,python2-numpy)
+ ))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f ; no 'setup.py test'
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'build 'change-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "scripts/pylmm_redis"
+ (("/usr/bin/python") (which "python"))
+ (("\\$PACKAGEDIR") (string-append out "/lib/python2.7/site-packages")))
+ ))))))
+
+ (home-page "http://genenetwork.org/")
+ (synopsis "LMM resolver")
+ (description "Fast and lightweight linear mixed-model (LMM) solver
+for use in genome-wide association studies (GWAS).")
+ (license license:agpl3+))))