aboutsummaryrefslogtreecommitdiff
path: root/gn/packages
diff options
context:
space:
mode:
authorRoel Janssen2016-03-01 13:24:13 +0100
committerRoel Janssen2016-03-01 13:24:13 +0100
commit1719e1f64e7532460de82afb3df391439eb87fb0 (patch)
tree314d9524e51766181fe611b276c7892567dc3770 /gn/packages
parent3d81b81500bca24e46bf83eb9750bdec19dd6862 (diff)
parentc9c9ff5f70e0fbb08c6b15d9cfc7a541b34cc818 (diff)
downloadguix-bioinformatics-1719e1f64e7532460de82afb3df391439eb87fb0.tar.gz
Merge branch 'master' of https://github.com/genenetwork/guix-bioinformatics
Diffstat (limited to 'gn/packages')
-rw-r--r--gn/packages/arrayfire.scm136
-rw-r--r--gn/packages/bioinformatics.scm290
-rw-r--r--gn/packages/genenetwork.scm43
-rw-r--r--gn/packages/hyphy.scm84
-rw-r--r--gn/packages/openfyba.scm61
-rw-r--r--gn/packages/python.scm99
-rw-r--r--gn/packages/ruby.scm2
-rw-r--r--gn/packages/statistics.scm222
8 files changed, 682 insertions, 255 deletions
diff --git a/gn/packages/arrayfire.scm b/gn/packages/arrayfire.scm
new file mode 100644
index 0000000..23ff0af
--- /dev/null
+++ b/gn/packages/arrayfire.scm
@@ -0,0 +1,136 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Dennis Mungai <dmngaie@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gn packages arrayfire)
+ #:use-module ((guix licenses))
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages gawk)
+ #:use-module (gnu packages cmake)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages textutils)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages ldc)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages linux))
+
+(define-public arrayfire
+ (package
+ (name "arrayfire")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://arrayfire.com/arrayfire_source/arrayfire-full-" version
+ ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "07pbw6vzny3z86y890c0rx7rk31ddchxrrdslk661iq512xppr0g"))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cmake" ,cmake)
+ ("gawk" ,gawk)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("boost" ,boost)
+ ("glfw" ,glfw)
+ ("curl" ,curl)
+ ("dbus" ,dbus)
+ ("enca" ,enca)
+ ("eudev" ,eudev)
+ ("glew" ,glew)
+ ("lapack" ,lapack)
+ ("libcap" ,libcap)
+ ("libjpeg" ,libjpeg)
+ ("libltdl" ,libltdl)
+ ("libtiff" ,libtiff)
+ ("libyajl" ,libyajl)
+ ("mesa-utils" ,mesa-utils)
+ ("mysql" ,mysql)
+ ("python" ,python-2)
+ ("freeimage" ,freeimage)
+ ("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("fftw-openmpi" ,fftw-openmpi)
+ ("glew" ,glew)
+ ("glu" ,glu)
+ ("openblas" ,openblas)
+ ("git" ,git)
+ ("cmake" ,cmake)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release -DBUILD_OPENCL=ON") #:tests? #f))
+ (synopsis "ArrayFire: a general purpose GPU library. https://arrayfire.com")
+ (description "ArrayFire is a high performance software library for parallel computing with an easy-to-use API. Its array based function set makes parallel programming simple.")
+ (home-page "http://arrayfire.com/")
+ (license (list gpl2 gpl2+ gpl3 gpl3+))))
+
+(define-public glfw
+ (package
+ (name "glfw")
+ (version "3.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/glfw/glfw/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08pixv8hd5xsccf7l8cqcijjqaq4k4da8qbp77wggal2fq445ika"))))
+ (build-system cmake-build-system)
+ (arguments `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON") #:tests? #f))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cmake" ,cmake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("curl" ,curl)
+ ("dbus" ,dbus)
+ ("enca" ,enca)
+ ("eudev" ,eudev)
+ ("glew" ,glew)
+ ("libcap" ,libcap)
+ ("libjpeg" ,libjpeg)
+ ("libltdl" ,libltdl)
+ ("libtiff" ,libtiff)
+ ("mesa-utils" ,mesa-utils)
+ ("randrproto" ,randrproto)
+ ("libxrandr" ,libxrandr)
+ ("xineramaproto" ,xineramaproto)
+ ("libxinerama" ,libxinerama)
+ ("libxcursor" ,libxcursor)
+ ("mysql" ,mysql)
+ ("python" ,python-2)))
+ (home-page "http://www.glfw.org/")
+ (synopsis "glfw is an Open Source, multi-platform library for creating windows with OpenGL contexts and receiving input and events.")
+ (description "glfw is an Open Source, multi-platform library for creating windows with OpenGL contexts and receiving input and events.")
+ (license (list gpl2))))
+
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index 3d27a72..ea4bf91 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -48,201 +48,77 @@
#:use-module (gn packages statistics)
#:use-module (srfi srfi-1))
-(define-public freebayes
- (let ((commit "3ce827d8ebf89bb3bdc097ee0fe7f46f9f30d5fb"))
- (package
- (name "freebayes")
- (version (string-append "v1.0.2-" (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ekg/freebayes.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32 "1sbzwmcbn78ybymjnhwk7qc5r912azy5vqz2y7y81616yc3ba2a2"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("cmake" ,cmake)
- ("htslib" ,htslib)
- ;;("openmpi" ,openmpi)
- ("zlib" ,zlib)
- ("python" ,python-2)
- ("perl" ,perl)
- ("bamtools-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/bamtools/archive/"
- "e77a43f5097ea7eee432ee765049c6b246d49baa" ".tar.gz"))
- (file-name "bamtools-src.tar.gz")
- (sha256
- (base32 "0rqymka21g6lfjfgxzr40pxz4c4fcl77jpy1np1li70pnc7h2cs1"))))
- ("vcflib-src"
- ,(origin
- (method url-fetch)
- (uri "https://github.com/vcflib/vcflib/archive/v1.0.0-rc1.tar.gz")
- (file-name "vcflib-v1.0.0-rc1.tar.gz")
- (sha256
- (base32 "0313cxnf77i74mz4xwkpdablw2a1nn7si9g5ar3kr0ipm02afizx"))))
- ;; These are submodules for the vcflib version used in freebayes
- ("tabixpp-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/tabixpp/archive/"
- "bbc63a49acc52212199f92e9e3b8fba0a593e3f7" ".tar.gz"))
- (file-name "tabixpp-src.tar.gz")
- (sha256
- (base32 "1s06wmpgj4my4pik5kp2lc42hzzazbp5ism2y4i2ajp2y1c68g77"))))
- ("intervaltree-src"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ekg/intervaltree/archive/"
- "dbb4c513d1ad3baac516fc1484c995daf9b42838" ".tar.gz"))
- (file-name "intervaltree-src.tar.gz")
- (sha256
- (base32 "19prwpn2wxsrijp5svfqvfcxl5nj7zdhm3jycd5kqhl9nifpmcks"))))
- ("smithwaterman-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/smithwaterman/archive/"
- "203218b47d45ac56ef234716f1bd4c741b289be1" ".tar.gz"))
- (file-name "smithwaterman-src.tar.gz")
- (sha256
- (base32 "1lkxy4xkjn96l70jdbsrlm687jhisgw4il0xr2dm33qwcclzzm3b"))))
- ("multichoose-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/multichoose/archive/"
- "73d35daa18bf35729b9ba758041a9247a72484a5" ".tar.gz"))
- (file-name "multichoose-src.tar.gz")
- (sha256
- (base32 "07aizwdabmlnjaq4p3v0vsasgz1xzxid8xcxcw3paq8kh9c1099i"))))
- ("fsom-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/fsom/archive/"
- "a6ef318fbd347c53189384aef7f670c0e6ce89a3" ".tar.gz"))
- (file-name "fsom-src.tar.gz")
- (sha256
- (base32 "0q6b57ppxfvsm5cqmmbfmjpn5qvx2zi5pamvp3yh8gpmmz8cfbl3"))))
- ("filevercmp-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/filevercmp/archive/"
- "1a9b779b93d0b244040274794d402106907b71b7" ".tar.gz"))
- (file-name "filevercmp-src.tar.gz")
- (sha256
- (base32 "0yp5jswf5j2pqc6517x277s4s6h1ss99v57kxw9gy0jkfl3yh450"))))
- ("fastahack-src"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ekg/fastahack/archive/"
- "c68cebb4f2e5d5d2b70cf08fbdf1944e9ab2c2dd" ".tar.gz"))
- (file-name "fastahack-src.tar.gz")
- (sha256
- (base32 "0j25lcl3jk1kls66zzxjfyq5ir6sfcvqrdwfcva61y3ajc9ssay2"))))
- ))
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)
- (add-after 'unpack 'unpack-submodule-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((unpack (lambda (source target)
- (with-directory-excursion target
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs source)
- "--strip-components=1"))))))
- (and
- (unpack "bamtools-src" "bamtools")
- (unpack "vcflib-src" "vcflib")
- (unpack "intervaltree-src" "intervaltree")
- (unpack "fastahack-src" "vcflib/fastahack")
- (unpack "filevercmp-src" "vcflib/filevercmp")
- (unpack "intervaltree-src" "vcflib/intervaltree")
- (unpack "multichoose-src" "vcflib/multichoose")
- (unpack "smithwaterman-src" "vcflib/smithwaterman")
- (unpack "tabixpp-src" "vcflib/tabixpp")))))
- (replace
- 'build
- (lambda* (#:key inputs make-flags #:allow-other-keys)
- (and
- ;; We must compile Bamtools before we can compile the main
- ;; project.
- (with-directory-excursion "bamtools"
- (system* "mkdir" "build")
- (with-directory-excursion "build"
- (and (zero? (system* "cmake" "../"))
- (zero? (system* "make")))))
- ;; We must compile vcflib before we can compile the main
- ;; project.
- (with-directory-excursion "vcflib"
- (with-directory-excursion "tabixpp"
- (zero? (system* "make")))
- (zero? (system* "make" "CC=gcc" "-Itabixpp")))
- (zero? (system* "make" "src/version_git.h"))
- (zero? (system* "make" "vcflib/Makefile")))))
- (replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
- (install-file "bin/freebayes" bin)
- (install-file "bin/bamleftalign" bin))))
- ;; (replace
- ;; 'check
- ;; (lambda* (#:key outputs #:allow-other-keys)
- ;; (with-directory-excursion "test"
- ;; (zero? (system* "make" "test")))))
- )))
- (home-page "https://github.com/ekg/freebayes")
- (synopsis "haplotype-based variant detector.")
- (description "FreeBayes is a Bayesian genetic variant detector designed to
-find small polymorphisms, specifically SNPs (single-nucleotide polymorphisms),
-indels (insertions and deletions), MNPs (multi-nucleotide polymorphisms), and
-complex events (composite insertion and substitution events) smaller than the
-length of a short-read sequencing alignment.")
- (license license:non-copyleft))))
+(define-public r-biocpreprocesscore
+ (package
+ (name "r-biocpreprocesscore")
+ (version "1.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "preprocessCore" version))
+ (sha256
+ (base32
+ "07isghjkqm91rg37l1fzpjrbq36b7w4pbsi95wwh6a8qq7r69z1n"))))
+ (properties
+ `((upstream-name . "BiocpreprocessCore")
+ (r-repository . bioconductor)))
+ (build-system r-build-system)
+ (home-page "http://bioconductor.org/packages/preprocessCore")
+ (synopsis "Preprocess functions for Bioconductor")
+ (description
+ "A library of core preprocessing routines.")
+ (license license:lgpl2.0+)))
(define-public r-wgcna
+ (let ((commit "425bc170cc0873ddbd414675ac40f6d4d724c7cb"))
(package
(name "r-wgcna")
- (version "1.48")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "WGCNA" version))
- (sha256
- (base32
- "18yl2v3s279saq318vd5hlwnqfm89rxmjjji778d2d26vviaf6bn"))))
+ (version (string-append "1.49-" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; (url "https://github.com/genenetwork/WGCNA.git")
+ (url "https://github.com/pjotrp/WGCNA.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "1zqnsb8s3065rq1y2y3l79zi8wmdwjkcjls96ypycrb7pmdil58j"))))
(properties `((upstream-name . "WGCNA")))
(build-system r-build-system)
- ;; (propagated-inputs
- ;; `( ;; ("r-annotationdbi" ,r-annotationdbi)
- ;; ("r-doparallel" ,r-doparallel)
- ;; ("r-dynamictreecut" ,r-dynamictreecut)
- ;; ("r-fastcluster" ,r-fastcluster)
- ;; ("r-foreach" ,r-foreach)
- ;; ("r-go.db" ,r-go.db)
- ;; ("r-grdevices" ,r-grdevices)
- ;; ("r-hmisc" ,r-hmisc)
- ;; ("r-impute" ,r-impute)
- ;; ("r-matrixstats" ,r-matrixstats)
- ;; ("r-parallel" ,r-parallel)
- ;; ("r-preprocesscore" ,r-preprocesscore)
- ;; ("r-splines" ,r-splines)
- ;; ("r-stats" ,r-stats)
- ;; ("r-survival" ,r-survival)
- ;; ("r-utils" ,r-utils)))
+ (propagated-inputs
+ `( ;; ("r-annotationdbi" ,r-annotationdbi)
+ ; ("r-biocparallel" ,r-biocparallel)
+ ("r-dynamictreecut" ,r-dynamictreecut)
+ ("r-doparallel" ,r-doparallel)
+ ("r-fastcluster" ,r-fastcluster)
+ ("r-foreach" ,r-foreach)
+ ("r-go-db" ,r-go-db)
+ ; ("r-grdevices" ,r-grdevices)
+ ("r-hmisc" ,r-hmisc)
+ ("r-impute" ,r-impute)
+ ("r-matrixstats" ,r-matrixstats)
+ ; ("r-parallel" ,r-parallel)
+ ("r-biocpreprocesscore" ,r-biocpreprocesscore)
+ ; ("r-splines" ,r-splines)
+ ; ("r-stats" ,r-stats)
+ ; ("r-survival" ,r-survival)
+ ; ("r-utils" ,r-utils)
+ ))
+ (arguments
+ `(
+ #:tests? #f)) ; no 'setup.py test'
(home-page
"http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/Rpackages/WGCNA/")
(synopsis
- "Weighted Correlation Network Analysis")
+ "Weighted gene correlation network analysis (wgcna)")
(description
- "Functions necessary to perform Weighted Correlation Network Analysis on high-dimensional data. Includes functions for rudimentary data cleaning, construction of correlation networks, module identification, summarization, and relating of variables and modules to sample traits. Also includes a number of utility functions for data manipulation and visualization.")
- (license license:gpl2+)))
+ "Functions necessary to perform Weighted Correlation Network
+Analysis on high-dimensional data. Includes functions for rudimentary
+data cleaning, construction of correlation networks, module
+identification, summarization, and relating of variables and modules
+to sample traits. Also includes a number of utility functions for
+data manipulation and visualization.")
+ (license license:gpl2+))))
(define-public qtlreaper
(package
@@ -277,7 +153,7 @@ test. For the permutation test, it performs only as many permutations
as are necessary to define the empirical P-value to a reasonable
precision. It also performs bootstrap resampling to estimate the
confidence region for the location of a putative QTL.")
- (license license:gpl2)))
+ (license license:gpl2+)))
(define-public plink2
(package
@@ -426,48 +302,6 @@ mixed model and some of its close relatives for genome-wide
association studies (GWAS).")
(license license:gpl3))))
-(define-public rdmd
- (let ((commit "4dba6877c"))
- (package
- (name "rdmd")
- (version "20160217")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/D-Programming-Language/tools.git")
- (commit commit)))
- (file-name (string-append name "-" commit))
- (sha256
- (base32
- "1pcx5lyqzrip86f4vv60x292rpvnwsq2hvl1znm9x9rn68f34m45"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check) ; There is no Makefile, so there's no 'make check'.
- (replace
- 'build
- (lambda _
- (zero? (system* "ldc2" "rdmd.d"))))
- (replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
- (mkdir-p bin)
- (copy-file "rdmd" (string-append bin "/rdmd"))))))))
- (native-inputs
- `(("ldc" ,ldc)))
- (home-page "https://github.com/D-Programming-Language/tools/")
- (synopsis "Tool for the D language which is used for compiling")
- (description
- "rdmd is a companion to the dmd compiler that simplifies the typical
-edit-compile-link-run or edit-make-run cycle to a rapid edit-run cycle. Like
-make and other tools, rdmd uses the relative dates of the files involved to
-minimize the amount of work necessary. Unlike make, rdmd tracks dependencies
-and freshness without requiring additional information from the user.")
- (license license:boost1.0))))
-
(define-public sambamba
(let ((commit "2ca5a2dbac5ab90c3b4c588519edc3edcb71df84"))
(package
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 2f755a6..aec305b 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -141,23 +141,24 @@
(license license:agpl3+))))
(define-public genenetwork2
- (let ((commit "9e9475053"))
+ (let ((commit "8c9de7e5a2016f1e5b7397be1a8e84396e3a25c5"))
(package
(name "genenetwork2")
- (version (string-append "2.0-" commit ))
+ (version (string-append "2.0-" (string-take commit 7) ))
(source (origin
(method git-fetch)
(uri (git-reference
;; (url "https://github.com/genenetwork/genenetwork2.git")
(url "https://github.com/pjotrp/genenetwork2.git")
(commit commit)))
- (file-name (string-append name "-" commit))
+ (file-name (string-append name "-" (string-take commit 7)))
(sha256
(base32
- "09hvy9mf4dnmkb8qg49viffzrxk53m2kr4r955m84dxaa5pdrjhd"))))
+ "1kgigzs4rs6zgbqbnm40rcljzz9prlwv7n2n9an57jk58bjgf6v8"))))
(propagated-inputs `( ;; propagated for development purposes
("python" ,python-2) ;; probably superfluous
("r" ,r)
+ ("r-wgcna" ,r-wgcna)
("redis" ,redis)
("mysql" ,mysql)
("gemma" ,gemma-git)
@@ -178,7 +179,7 @@
("python2-pandas" ,python2-pandas)
("python2-parallel" ,python2-parallel)
("python2-passlib" ,python2-passlib)
- ("python2-piddle" ,python2-piddle)
+ ("python2-piddle-gn" ,python2-piddle-gn)
("python2-redis" ,python2-redis)
("python2-requests" ,python2-requests)
("python2-rpy2" ,python2-rpy2)
@@ -202,3 +203,35 @@
;; ./pre-inst-env guix download http://files.genenetwork.org/raw_database/db_webqtl_s.zip
;; 0sscjh0wml2lx0mb43vf4chg9gpbfi7abpjxb34n3kyny9ll557x
+
+(define-public genenetwork2-database-small
+ (let ((md5 "93e745e9c"))
+ (package
+ (name "genenetwork2-database-small")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "http://files.genenetwork.org/raw_database/db_webqtl_s.zip")
+ (file-name (string-append name "-" md5))
+ (sha256
+ (base32 "0sscjh0wml2lx0mb43vf4chg9gpbfi7abpjxb34n3kyny9ll557x"))))
+ (build-system trivial-build-system)
+ (native-inputs `(("unzip" ,unzip)
+ ("source" ,source)))
+
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip"))
+ )
+ (and (mkdir "db")
+ (zero? (system* unzip source "-d" "db"))
+ (chdir "db"))))))
+ (home-page "http://genenetwork.org/")
+ (synopsis "Small database to run on genenetwork")
+ (description "Genenetwork installation + database.")
+ (license license:agpl3+))))
+
diff --git a/gn/packages/hyphy.scm b/gn/packages/hyphy.scm
new file mode 100644
index 0000000..fea73a4
--- /dev/null
+++ b/gn/packages/hyphy.scm
@@ -0,0 +1,84 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Dennis Mungai <dmngaie@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gn packages hyphy)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages gawk)
+ #:use-module (gnu packages cmake)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages textutils)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages linux))
+
+(define-public hyphy
+ (package
+ (name "hyphy")
+ (version "2.2.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/veg/hyphy/archive/" version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00i3609nywb1xfq50p3kvfbvahql241ciq23jrf67z0yp4y5l5a9"))))
+ (inputs
+ `(("python" ,python-2)
+ ("fftw-openmpi" ,fftw-openmpi)))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack `bootstrap
+ (lambda _
+ (zero? (system* "make" "MPI")))))))
+ (arguments
+ `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
+ #:tests? #f))
+ (synopsis "hyphy: an open-source software package for the analysis
+of genetic sequences using techniques in phylogenetics, molecular
+evolution, and machine learning.")
+ (description "HyPhy is an open-source software package for the
+analysis of genetic sequences using techniques in phylogenetics,
+molecular evolution, and machine learning. It features a complete
+graphical user interface (GUI) and a rich scripting language for
+limitless customization of analyses. Additionally, HyPhy features
+support for parallel computing environments (via message passing
+interface (MPI)) and it can be compiled as a shared library and called
+from other programming environments such as Python and R. ")
+ (home-page "http://hyphy.org")
+ (license license:expat)))
+
+
+
diff --git a/gn/packages/openfyba.scm b/gn/packages/openfyba.scm
new file mode 100644
index 0000000..2b20d09
--- /dev/null
+++ b/gn/packages/openfyba.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Dennis Mungai <dmngaie@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gn packages openfyba)
+ #:use-module ((guix licenses))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages textutils)
+ #:use-module (gnu packages base)
+ ;;#:use-module (gnu packages tls)
+ #:use-module (gnu packages zip)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages bootstrap)
+ #:use-module (guix git-download))
+
+(define-public openfyba
+ (package
+ (name "openfyba")
+ (version "4.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/kartverket/fyba/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ya1agi78d386skq353dk400fl11q6whfqmv31qrkn4g5vamixlr"))))
+ (inputs `(("zip" ,zip)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("libgcrypt" ,libgcrypt)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack `bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (home-page "http://labs.kartverket.no/sos/")
+ (synopsis "source code release of the FYBA library")
+ (description "OpenFYBA is the source code release of the FYBA library.")
+ (license (list gpl2))))
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 8f2bc80..7781521 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -357,32 +357,89 @@ project)")
(description #f)
(license #f)))
-(define-public python2-piddle
+(define-public python2-pil-1.1.6
(package
- (name "python2-piddle")
- (version "1.0.15")
+ (name "python2-pil")
+ (version "1.1.6")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- ;; http://sourceforge.net/projects/numpy/files/Old%20Numarray/1.5.2/numarray-1.5.2.tar.gz/download
- "mirror://sourceforge/piddle/piddle-" version ".zip"
- ))
- ;; (file-name (string-append name "-" version ".zip"))
- (sha256
- (base32
- "0jaxfsrcgqb5cf2wznxnpdws5khlrdixmg85lrhq2zl9cy6dfdya"))))
- (native-inputs
- `(("unzip" ,unzip)))
-
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://effbot.org/downloads/Imaging-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "141zidl3s9v4vfi3nsbg42iq1lc2a932gprqr1kij5hrnn53bmvx"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Adapt to newer freetype. As the package is unmaintained upstream,
+ ;; there is no use in creating a patch and reporting it.
+ '(substitute* "_imagingft.c"
+ (("freetype/")
+ "freetype2/")))))
(build-system python-build-system)
- ;; (native-inputs
- ;; `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("python-setuptools" ,python-setuptools)
+ ("zlib" ,zlib)))
(arguments
+ ;; Only the fork python-pillow works with Python 3.
`(#:python ,python-2
- #:tests? #f
- )) ; no 'setup.py test' really!
- (home-page "http://www.numpy.org/")
+ #:tests? #f ; no check target
+ #:phases
+ (alist-cons-before
+ 'build 'configure
+ ;; According to README and setup.py, manual configuration is
+ ;; the preferred way of "searching" for inputs.
+ ;; lcms is not found, TCL_ROOT refers to the unavailable tkinter.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((jpeg (assoc-ref inputs "libjpeg"))
+ (zlib (assoc-ref inputs "zlib"))
+ (tiff (assoc-ref inputs "libtiff"))
+ (freetype (assoc-ref inputs "freetype")))
+ (substitute* "setup.py"
+ (("JPEG_ROOT = None")
+ (string-append "JPEG_ROOT = libinclude(\"" jpeg "\")"))
+ (("ZLIB_ROOT = None")
+ (string-append "ZLIB_ROOT = libinclude(\"" zlib "\")"))
+ (("TIFF_ROOT = None")
+ (string-append "TIFF_ROOT = libinclude(\"" tiff "\")"))
+ (("FREETYPE_ROOT = None")
+ (string-append "FREETYPE_ROOT = libinclude(\""
+ freetype "\")")))))
+ %standard-phases)))
+ (home-page "http://www.pythonware.com/products/pil/")
+ (synopsis "Python Imaging Library")
+ (description "The Python Imaging Library (PIL) adds image processing
+capabilities to the Python interpreter.")
+ (license (license:x11-style
+ "file://README"
+ "See 'README' in the distribution."))))
+
+(define-public python2-piddle-gn
+ (package
+ (name "python2-piddle")
+ (version "1.0.15-gn")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://files.genenetwork.org/software/contrib/piddle-"
+version ".tgz"))
+ (sha256
+ (base32
+ "05gjnn31v7p0kh58qixrpcizcxqf3b7zv4a5kk8nsmqwgxh0c6gq"))))
+
+ (build-system python-build-system)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (arguments
+ `(
+ #:python ,python-2
+ #:tests? #f ; no 'setup.py test' really!
+ ))
+ (home-page #f)
(synopsis "Canvas drawing library for python2 (old!)")
(description #f)
(license #f)))
diff --git a/gn/packages/ruby.scm b/gn/packages/ruby.scm
index 0e1fa88..bebc678 100644
--- a/gn/packages/ruby.scm
+++ b/gn/packages/ruby.scm
@@ -16,7 +16,7 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (gnu packages ruby)
+(define-module (gn packages ruby)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 2d83816..2c9ebda 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -18,6 +18,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cpio)
#:use-module (gnu packages file)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages machine-learning)
@@ -39,6 +40,227 @@
#:use-module (gnu packages bootstrap)
#:use-module (srfi srfi-1))
+(define-public r-acepack
+(package
+ (name "r-acepack")
+ (version "1.3-3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acepack" version))
+ (sha256
+ (base32
+ "13ry3vyys12iplb14jfhmkrl9g5fxg3iijiggq4s4zb5m5436b1y"))))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (home-page
+ "http://cran.r-project.org/web/packages/acepack")
+ (synopsis
+ "ace() and avas() for selecting regression transformations")
+ (description
+ "ACE and AVAS methods for choosing regression transformations.")
+ (license license:x11)))
+
+(define-public r-latticeextra
+(package
+ (name "r-latticeextra")
+ (version "0.6-28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "latticeExtra" version))
+ (sha256
+ (base32
+ "1hkyqsa7klk5glj9y1hg3rxr5qilqw8h0017zc4c3nps7lr9a1kq"))))
+ (properties `((upstream-name . "latticeExtra")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `( ;;("r-grdevices" ,r-grdevices)
+ ("r-gridbase" ,r-gridbase)
+ ("r-lattice" ,r-lattice)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ))
+ (home-page
+ "http://latticeextra.r-forge.r-project.org/")
+ (synopsis
+ "Extra Graphical Utilities Based on Lattice")
+ (description
+ "Building on the infrastructure provided by the lattice package, this package provides several new high-level functions and methods, as well as additional utilities such as panel and axis annotation functions.")
+ (license license:gpl2+)))
+
+(define-public r-formula
+ (package
+ (name "r-formula")
+ (version "1.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Formula" version))
+ (sha256
+ (base32
+ "02in5325zzrqbhlygx6s0dinj6ymw845q70y56frqacv25ayzcax"))))
+ (properties `((upstream-name . "Formula")))
+ (build-system r-build-system)
+ (home-page
+ "http://cran.r-project.org/web/packages/Formula")
+ (synopsis "Extended Model Formulas")
+ (description
+ "Infrastructure for extended formulas with multiple parts on the right-hand side and/or multiple responses on the left-hand side.")
+ (license #f))
+)
+
+(define-public r-hmisc
+(package
+ (name "r-hmisc")
+ (version "3.17-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Hmisc" version))
+ (sha256
+ (base32
+ "110w5hbrl10isslqs0iq6w2ll0dafqyqznb50cdcallnlnvbvxrg"))))
+ (properties `((upstream-name . "Hmisc")))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (arguments
+ `(#:tests? #f)) ; no 'setup.py test'
+ (propagated-inputs
+ `(("r-acepack" ,r-acepack)
+ ; ("r-cluster" ,r-cluster)
+ ; ("r-foreign" ,r-foreign)
+ ("r-formula" ,r-formula)
+ ("r-ggplot2" ,r-ggplot2)
+ ; ("r-grid" ,r-grid)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gtable" ,r-gtable)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ; ("r-methods" ,r-methods)
+ ; ("r-nnet" ,r-nnet)
+ ; ("r-rpart" ,r-rpart)
+ ; ("r-survival" ,r-survival)))
+ ))
+ (home-page
+ "http://biostat.mc.vanderbilt.edu/Hmisc")
+ (synopsis "Harrell Miscellaneous")
+ (description
+ "Contains many functions useful for data analysis, high-level graphics, utility operations, functions for computing sample size and power, importing and annotating datasets, imputing missing values, advanced table making, variable clustering, character string manipulation, conversion of R objects to LaTeX code, and recoding variables.")
+ (license license:gpl2+)))
+
+(define-public r-doparallel
+(package
+ (name "r-doparallel")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "doParallel" version))
+ (sha256
+ (base32
+ "1mddx25l25pw9d0csnx2q203dbg5hbrhkr1f08kw0p02a1lln0kh"))))
+ (properties `((upstream-name . "doParallel")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-foreach" ,r-foreach)
+ ("r-iterators" ,r-iterators)
+ ;; ("r-parallel" ,r-parallel)
+ ))
+ (home-page
+ "http://cran.r-project.org/web/packages/doParallel")
+ (synopsis
+ "Foreach Parallel Adaptor for the 'parallel' Package")
+ (description
+ "Provides a parallel backend for the %dopar% function using the parallel package.")
+ (license license:gpl2+)))
+
+(define-public r-iterators
+(package
+ (name "r-iterators")
+ (version "1.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "iterators" version))
+ (sha256
+ (base32
+ "1f057pabs7ss9h1n244can26qsi5n2k3salrdk0b0vkphlrs4kmf"))))
+ (build-system r-build-system)
+ ;; (propagated-inputs `(("r-utils" ,r-utils)))
+ (home-page
+ "http://cran.r-project.org/web/packages/iterators")
+ (synopsis "Provides Iterator Construct for R")
+ (description
+ "Support for iterators, which allow a programmer to traverse through all the elements of a vector, list, or other collection of data.")
+ (license #f)))
+
+(define-public r-foreach
+(package
+ (name "r-foreach")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "foreach" version))
+ (sha256
+ (base32
+ "10aqsd3rxz03s1qdb6gsb1cj89mj4vmh491zfpin4skj1xvkzw0y"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-iterators" ,r-iterators)))
+ (home-page
+ "http://cran.r-project.org/web/packages/foreach")
+ (synopsis
+ "Provides Foreach Looping Construct for R")
+ (description
+ "Support for the foreach looping construct. Foreach is an idiom that allows for iterating over elements in a collection, without the use of an explicit loop counter. This package in particular is intended to be used for its return value, rather than for its side effects. In that sense, it is similar to the standard lapply function, but doesn't require the evaluation of a function. Using foreach without side effects also facilitates executing the loop in parallel.")
+ (license #f))
+)
+
+(define-public r-fastcluster
+(package
+ (name "r-fastcluster")
+ (version "1.1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastcluster" version))
+ (sha256
+ (base32
+ "0x2prrsnqi5iqx23ki6y2agndjq8058ph6s703i4avrqi1q1w1q8"))))
+ (build-system r-build-system)
+ (home-page
+ "http://danifold.net/fastcluster.html")
+ (synopsis
+ "Fast Hierarchical Clustering Routines for R and Python")
+ (description
+ "This is a two-in-one package which provides interfaces to both R and Python. It implements fast hierarchical, agglomerative clustering routines. Part of the functionality is designed as drop-in replacement for existing routines: \"linkage\" in the SciPy package \"scipy.cluster.hierarchy\", \"hclust\" in R's \"stats\" package, and the \"flashClust\" package. It provides the same functionality with the benefit of a much faster implementation. Moreover, there are memory-saving routines for clustering of vector data, which go beyond what the existing packages provide. For information on how to install the Python files, see the file INSTALL in the source distribution.")
+ (license #f)))
+
+(define-public r-dynamictreecut
+(package
+ (name "r-dynamictreecut")
+ (version "1.62")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dynamicTreeCut" version))
+ (sha256
+ (base32
+ "1y11gg6k32wpsyb10kdv176ivczx2jlizs1xsrjrs6iwbncwzrkp"))))
+ (properties
+ `((upstream-name . "dynamicTreeCut")))
+ (build-system r-build-system)
+ ; (propagated-inputs `(("r-stats" ,r-stats)))
+ (home-page
+ "http://www.genetics.ucla.edu/labs/horvath/CoexpressionNetwork/BranchCutting/")
+ (synopsis
+ "Methods for detection of clusters in hierarchical clustering dendrograms.")
+ (description
+ "Contains methods for detection of clusters in hierarchical clustering dendrograms.")
+ (license license:gpl2+)))
+
(define-public r-rcppeigen
(package
(name "r-rcppeigen")