aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner2020-06-04 02:00:26 -0500
committerEfraim Flashner2020-06-04 02:03:49 -0500
commit2d0841d7e10f987c21c95347477e32d2440abd9b (patch)
tree63ff23e907b260ed4bc2db772c696aadab298519 /gn/packages/web.scm
parent21efb11c56e6b9cb49450467c5729433955abc42 (diff)
downloadguix-bioinformatics-2d0841d7e10f987c21c95347477e32d2440abd9b.tar.gz
mod-python-24: Link to all python2.4 dependencies
Diffstat (limited to 'gn/packages/web.scm')
-rw-r--r--gn/packages/web.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gn/packages/web.scm b/gn/packages/web.scm
index 8b44e23..c683f5d 100644
--- a/gn/packages/web.scm
+++ b/gn/packages/web.scm
@@ -4,10 +4,10 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages fonts)
- #:use-module (gnu packages onc-rpc)
#:use-module (gn packages python24)
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages web)
#:use-module (guix packages)
#:use-module (guix download)
@@ -264,12 +264,17 @@ connections and other data between hits and access to Apache internals.")
(replace 'bootstrap
(lambda* (#:key inputs #:allow-other-keys)
(let* ((python (assoc-ref inputs "python"))
- (py-version (python:python-version python)))
+ (tcl (assoc-ref inputs "tcl"))
+ (py-version (python:python-version python))
+ (tcl-version ,(version-major+minor (package-version tcl))))
(substitute* "configure.in"
(("PY_LIBS=.*")
(string-append "PY_LIBS=-L" python "/lib/python" py-version "\n"))
(("PY_LDFLAGS=.*")
- (string-append "PY_LDFLAGS=-lpython" py-version "\n"))
+ (string-append "PY_LDFLAGS=\"-lpython" py-version
+ " -lreadline -lssl -lcrypto"
+ " -ltk" tcl-version " -ltcl" tcl-version
+ " -lgdbm -ltirpc -lnsl -lz\"\n"))
(("PY_INCLUDES=.*")
(string-append "PY_INCLUDES=-I" python "/include/python" py-version "\n")))
(invoke "autoreconf" "-vfi"))))
@@ -285,16 +290,10 @@ connections and other data between hits and access to Apache internals.")
`(("autoconf" ,autoconf)
("automake" ,automake)
("flex" ,(@ (gnu packages flex) flex))))
- (propagated-inputs
- `(
- ("readline" ,readline)
- ))
(inputs
`(("httpd" ,httpd)
- ("libnsl" ,libnsl)
- ("libtirpc" ,libtirpc)
- ("python" ,python-2.4)))))
-
+ ("python" ,python-2.4)
+ ,@(package-inputs python-2.4)))))
(define-public web-font-awesome
(package