aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/statistics.scm
diff options
context:
space:
mode:
authorpjotrp2016-02-20 13:03:51 +0000
committerpjotrp2016-02-20 13:03:51 +0000
commite472db7bd929f8b511b0cd5e777dff25c1fbc692 (patch)
treeca30b63e8be7ffe81fd771199bf1c12a3c9e8071 /gn/packages/statistics.scm
parentd39fc4892dcc75a581ded476bf8bd2181348f159 (diff)
downloadguix-bioinformatics-e472db7bd929f8b511b0cd5e777dff25c1fbc692.tar.gz
Added package for pylmm
Diffstat (limited to 'gn/packages/statistics.scm')
-rw-r--r--gn/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gn/packages/statistics.scm b/gn/packages/statistics.scm
index 065826e..c10ba29 100644
--- a/gn/packages/statistics.scm
+++ b/gn/packages/statistics.scm
@@ -148,3 +148,27 @@
"R/lmmlite")
(home-page "https://github.com/kbroman/")
(license license:asl2.0)))
+
+(define-public pylmm-gn2
+ (let ((commit "f5c9e2378"))
+ (package
+ (name "pylmm-gn2")
+ (version (string-append "1.0-" commit ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/genenetwork/pylmm.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32
+ "10qb5dpwqjdiq9gakl7m4p4ckjlc701mzqpgbhp89w1aysddj1c7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no 'setup.py test'
+ (home-page "http://genenetwork.org/")
+ (synopsis "LMM resolver")
+ (description "Fast and lightweight linear mixed-model (LMM) solver
+for use in genome-wide association studies (GWAS).")
+ (license license:agpl3+))))