aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/python.scm
diff options
context:
space:
mode:
authorpjotrp2016-01-23 10:35:37 +0300
committerpjotrp2016-01-23 10:35:37 +0300
commitd1c83a621fe4d08e2bb536ed4844dcb473db4d27 (patch)
tree3a1479277fdfcb8830006d10c25fbfb56aaaa930 /gn/packages/python.scm
parent78c230aba4f3e5f0821485cb9c20344e353cc851 (diff)
downloadguix-bioinformatics-d1c83a621fe4d08e2bb536ed4844dcb473db4d27.tar.gz
Started on gn1 package
Added python2-numarray 1.5.2
Diffstat (limited to 'gn/packages/python.scm')
-rw-r--r--gn/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gn/packages/python.scm b/gn/packages/python.scm
index 7829932..8f53d54 100644
--- a/gn/packages/python.scm
+++ b/gn/packages/python.scm
@@ -175,3 +175,31 @@ powerful language for representing information.")
(define-public python2-shellescape
(package-with-python2 python-shellescape))
+
+(define-public python2-numarray
+ (package
+ (name "python2-numarray")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ ;; http://sourceforge.net/projects/numpy/files/Old%20Numarray/1.5.2/numarray-1.5.2.tar.gz/download
+ "mirror://sourceforge/numpy/numarray-" version ".tar.gz"
+ ))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x1i4j7yni7k4p9kjxs1lgln1psdmyrz65wp2yr35yn292iw2vbg"))))
+ (build-system python-build-system)
+ ;; (native-inputs
+ ;; `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no 'setup.py test' really!
+ (home-page "http://www.numpy.org/")
+ (synopsis "Numerical library array processing of numbers, strings, records and objects")
+ (description
+ "Numarray is an array processing package designed to efficiently manipulate large multi-dimensional arrays. Numarray is modelled after Numeric and features c-code generated from python template scripts, the capacity to operate directly on arrays in files, and improved type promotions. Numarray provides support for manipulating arrays consisting of numbers, strings, records, or objects using the same basic infrastructure and syntax. Numarray is now part of the
+numpy package, though some legacy software still uses the older versions.")
+ (license license:gpl2))) ; actualy PyRAF http://www.stsci.edu/resources/software_hardware/pyraf/LICENSE