aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/perl.scm
diff options
context:
space:
mode:
authorpjotrp2017-07-16 17:06:45 +0200
committerpjotrp2017-07-16 17:06:45 +0200
commit3315af153d1abe42bb5592d59b7f56bd53a2ee28 (patch)
treee0ec89724d6f4906f593308343c41339b5e31cb2 /gn/packages/perl.scm
parentcc6787454df46e1a1bdc2c20a6a983113188e36d (diff)
downloadguix-bioinformatics-3315af153d1abe42bb5592d59b7f56bd53a2ee28.tar.gz
Added package for logtodo
Diffstat (limited to 'gn/packages/perl.scm')
-rw-r--r--gn/packages/perl.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gn/packages/perl.scm b/gn/packages/perl.scm
index c1b7946..bff7208 100644
--- a/gn/packages/perl.scm
+++ b/gn/packages/perl.scm
@@ -60,3 +60,36 @@
(synopsis "Parse and format time values")
(description "ParseDate")
(license #f)))
+
+(define-public logtodo
+ (let ((commit "acda8f2a7aa67f590ae03487306794b039eaba68"))
+ (package
+ (name "logtodo")
+ (version (string-append "1.0.5-" (string-take commit 7) ))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; (url "https://github.com/genenetwork/genenetwork2.git")
+ (url "https://gitlab.com/pjotrp/logtodo.git")
+ (commit commit)))
+ (file-name (string-append name "-" (string-take commit 7)))
+ (sha256
+ (base32
+ "0bcjnb09sxgv7c45nk4sipxw38a6ldhmijgn614h7bibwqyvybmc"))))
+ (build-system perl-build-system)
+ (propagated-inputs `(("perl-time-parsedate" ,perl-time-parsedate)))
+ (arguments
+ `(
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "logtodo" (string-append out "/bin"))))))
+ #:tests? #f)) ; no 'setup.py test' really!
+ (home-page "https://gitlab.com/pjotrp/logtodo")
+ (synopsis "Pjotr's time logger")
+ (description "None")
+ (license license:gpl2+))))