aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/genenetwork.scm
diff options
context:
space:
mode:
authorPjotr Prins2019-09-05 03:48:35 -0500
committerPjotr Prins2019-09-05 03:48:35 -0500
commit04c25fe599e568499769f67f43f7af6c2ab3298b (patch)
tree7a127cec7718fa993cb486baf38711035e34e08c /gn/packages/genenetwork.scm
parent90585724d8fb4a7d2ef4ec926351e0d108e1982f (diff)
downloadguix-bioinformatics-04c25fe599e568499769f67f43f7af6c2ab3298b.tar.gz
Reaper
Diffstat (limited to 'gn/packages/genenetwork.scm')
-rw-r--r--gn/packages/genenetwork.scm44
1 files changed, 3 insertions, 41 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 5f18c69..501b300 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -114,10 +114,10 @@
(license license:agpl3+))))
(define-public python2-qtlreaper
- (let ((commit "dd9c7fb2a9d5fa40b4054e1bcb7c57905d98d5f8"))
+ (let ((commit "442c217b90393380a8634ff8636b44992f5c53dd"))
(package
(name "python2-qtlreaper")
- (version (string-append "1.1-gn2-" (string-take commit 7) ))
+ (version (string-append "1.11-gn2-" (string-take commit 7) ))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -127,7 +127,7 @@
(file-name (string-append name "-" (string-take commit 7)))
(sha256
(base32
- "1ldcvyk8y8w6f4ci04hzx85sknd5a3h424p5bfi4fz32sm2p7fja"))))
+ "1rrbm1ap2zzyjxmrs9aa1d18sgiba5dhj1fmkl7wmab06jv3j1hm"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2
@@ -181,44 +181,6 @@ bootstrap resampling to estimate the confidence region for the
location of a putative QTL.")
(license license:gpl2+))))
-(define-public python-qtlreaper
- (let ((commit "dd9c7fb2a9d5fa40b4054e1bcb7c57905d98d5f8"))
- (package
- (name "python-qtlreaper")
- (version (string-append "1.1-gn2-" (string-take commit 7) ))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- ;; (url "https://github.com/genenetwork/genenetwork2.git")
- (url "https://github.com/pjotrp/QTLreaper.git")
- (commit commit)))
- (file-name (string-append name "-" (string-take commit 7)))
- (sha256
- (base32
- "1ldcvyk8y8w6f4ci04hzx85sknd5a3h424p5bfi4fz32sm2p7fja"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'fix-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("./test/example1.py" "./test/example2.py")
- (("/usr/bin/python") (which "python3"))))))
- #:tests? #f)) ; no 'setup.py test' really!
- (home-page "http://qtlreaper.sourceforge.net/")
- (synopsis "Scan expression data for QTLs")
- (description
- "Batch-oriented version of WebQTL. It requires, as input,
-expression data from members of a set of recombinant inbred lines and
-genotype information for the same lines. It searches for an
-association between each expression trait and all genotypes and
-evaluates that association by a permutation test. For the permutation
-test, it performs only as many permutations as are necessary to define
-the empirical P-value to a reasonable precision. It also performs
-bootstrap resampling to estimate the confidence region for the
-location of a putative QTL.")
- (license license:gpl2+))))
(define-public rust-qtlreaper
(let ((commit "2e7fed6d45b0b602d80fa2a55835f96ef1cba9e3")