aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/genenetwork.scm
diff options
context:
space:
mode:
authorBonfaceKilz2020-10-27 15:21:07 +0300
committerBonfaceKilz2020-10-31 14:45:39 +0300
commit117a3192ab26d8fd1caeca648533cc58ed420f06 (patch)
tree41b39160b06a5be86c60f150feffd2a1ca82802b /gn/packages/genenetwork.scm
parentdee0f16c67d7c62316aa417478f7d3d690c9f47b (diff)
downloadguix-bioinformatics-117a3192ab26d8fd1caeca648533cc58ed420f06.tar.gz
gn: Delete genenetwork3 package
* gn/packages/genenetwork.scm (genenetwork3): Delete it. The python3 version of genenetwork2 is already packaged as python3-genenetwork2.
Diffstat (limited to 'gn/packages/genenetwork.scm')
-rw-r--r--gn/packages/genenetwork.scm132
1 files changed, 0 insertions, 132 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index 7946f70..6641ae6 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -591,138 +591,6 @@ Graphical Fragment Assembly} files and related formats.")
written in C")
(license license:agpl3+))))
-(define-public genenetwork3
- (let (;; (commit "1538ffd33af19e6ac922b4ee85fe701408968dfd")
- (commit "5bff4f49dffb4ac982d36cd0d39e0a9ec6bc66e9"))
- (package
- (name "genenetwork3")
- (version (string-append "2.10rc5-" (string-take commit 7) ))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fredmanglis/genenetwork2.git")
- ;; (url "https://pjotrp@gitlab.com/genenetwork/gn2_diet.git")
- ;; (url "https://github.com/genenetwork/genenetwork2_diet.git")
- (commit commit)))
- (file-name (string-append name "-" version))
- (sha256
- (base32
- "0klgjra2qisfzs8mk0s8vzdr190l4n56xcm66dk0asqs7zswi8di"
- ;; "0ji929xgzypyhchcfy9xa1sz04w322ibs2khc8s3qiddxjqdglrz"
- ))))
- (propagated-inputs ;; propagated for development purposes
- `(;; Agnostic to Python
- ("r" ,r)
- ("git" ,git)
- ("vim" ,vim)
- ("grep" ,grep)
- ("which" ,which)
- ("r-ctl" ,r-ctl)
- ("r-qtl" ,r-qtl)
- ("redis" ,redis)
- ("mariadb" ,mariadb)
- ("nginx" ,nginx)
- ("r-wgcna" ,r-wgcna)
- ;; ("r-phewas" ,r-phewas)
- ("coreutils" ,coreutils)
- ("gemma" ,gemma-gn2-git)
- ("plink-ng-gn" ,plink-ng-gn)
- ("python-lxml" ,python-lxml) ;; used for the tests
- ("gemma-wrapper" ,gemma-wrapper)
- ("python-unittest" ,python-unittest2) ;; used for the tests
- ("python-parameterized" ,python-parameterized) ;; used for the tests
- ("genenetwork2-files-small" ,genenetwork2-files-small)
- ("javascript-twitter-post-fetcher" ,javascript-twitter-post-fetcher)
- ("javascript-cytoscape" ,javascript-cytoscape)
- ("javascript-panzoom" ,javascript-cytoscape-panzoom)
- ("javascript-qtip" ,javascript-cytoscape-qtip)
- ("javascript-chroma" ,javascript-chroma)
- ;; With Python3 support
- ("gunicorn" ,gunicorn)
- ("python-rpy2" ,python-rpy2)
- ("python-flask" ,python-flask)
- ("python-scipy" ,python-scipy)
- ("python-numpy" ,python-numpy)
- ("python-redis" ,python-redis)
- ("python-scipy" ,python-scipy)
- ("python-pillow" ,python-pillow)
- ("python-reaper" ,python-reaper)
- ("python-pyyaml" ,python-pyyaml)
- ("python-jinja2" ,python-jinja2)
- ("python-pandas" ,python-pandas)
- ("python-htmlgen" ,python-htmlgen)
- ("python-passlib" ,python-passlib)
- ("python-wrapper" ,python-wrapper)
- ("python-requests" ,python-requests)
- ("python-cssselect" ,python-cssselect)
- ("python-sqlalchemy" ,python-sqlalchemy)
- ("python-setuptools" ,python-setuptools)
- ("python-simplejson" ,python-simplejson)
- ("python-xlsxwriter" ,python-xlsxwriter)
- ("python-mysqlclient" ,python-mysqlclient)
- ("python-elasticsearch" ,python-elasticsearch)
- ("python-flask-sqlalchemy" ,python-flask-sqlalchemy)
-
- ;; Without Python3 support
- ;; ("python-qtlreaper" ,python-qtlreaper) ;; Run as an external program
- ;; ("pylmm-gn2" ,pylmm-gn2) ;; To be run as an external python2 program
- ;; ("python2-numarray" ,python2-numarray) ;; Update gn2 code and drop this (IMPORTANT)
- ;; ("python2-htmlgen-gn" ,python2-htmlgen-gn) ;; pjotrp and zsloan to give directions
- ))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases
- %standard-phases
- (delete 'reset-gzip-timestamps)
- (add-after
- 'unpack 'fix-paths-scripts
- (lambda _
- (substitute* "bin/genenetwork2"
- (("/usr/bin/env") (which "env"))
- (("python ") (string-append (which "python") " "))
- (("readlink") (which "readlink"))
- (("dirname") (which "dirname"))
- (("basename") (which "basename"))
- (("cat") (which "cat"))
- (("echo") (which "echo"))
- (("redis-server") (which "redis-server"))
- (("git") (which "git"))
- (("grep") (which "grep"))
- (("rm") (which "rm"))
- (("which") (which "which")))
- #t))
- (add-before
- 'install 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((datafiles
- (string-append
- (assoc-ref inputs "genenetwork2-files-small")
- "/share/genenetwork2" ))
- ;; (pylmmcmd
- ;; (string-append
- ;; (assoc-ref inputs "pylmm-gn2") "/bin/pylmm_redis"))
- (plink2cmd
- (string-append
- (assoc-ref inputs "plink-ng-gn") "/bin/plink2"))
- (gemmacmd
- (string-append (assoc-ref inputs "gemma") "/bin/gemma")))
-
- (substitute*
- '("etc/default_settings.py")
- (("^GENENETWORK_FILES +=.*")
- (string-append "GENENETWORK_FILES = \"" datafiles "\"\n" ))
- (("^PYLMM_COMMAND =.*")
- (string-append "PYLMM_COMMAND = \"" pylmmcmd "\"\n" ))
- (("^PLINK_COMMAND =.*")
- (string-append "PLINK_COMMAND = \"" plink2cmd "\"\n" ))
- (("^GEMMA_COMMAND =.*")
- (string-append "GEMMA_COMMAND = \"" gemmacmd "\"\n")))))))
- #:tests? #f)) ; no 'setup.py test'
- (home-page "http://genenetwork.org/")
- (synopsis "Full genenetwork services")
- (description "Genenetwork installation sumo.")
- (license license:agpl3+))))
(define-public genenetwork1
(let ((commit "acf65ac9ae4be395c07c1629758f7408bf4eab5f") ; June 3, 2020