aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/genenetwork.scm
diff options
context:
space:
mode:
authorpjotrp2016-09-29 08:51:42 +0000
committerpjotrp2016-09-29 08:51:42 +0000
commit9351ff09f6ac8c557ce3e847518f04f281e7b3dc (patch)
treed21e302bdd7c1dc6dfc52206c843e415d72ddc43 /gn/packages/genenetwork.scm
parente73d1d766905b5f98f68d1799a88a3b86c1ff9f9 (diff)
downloadguix-bioinformatics-9351ff09f6ac8c557ce3e847518f04f281e7b3dc.tar.gz
Move qtlreaper to genenetwork.scm
Diffstat (limited to 'gn/packages/genenetwork.scm')
-rw-r--r--gn/packages/genenetwork.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gn/packages/genenetwork.scm b/gn/packages/genenetwork.scm
index a7317c6..d8a1813 100644
--- a/gn/packages/genenetwork.scm
+++ b/gn/packages/genenetwork.scm
@@ -87,6 +87,41 @@
(description #f)
(license #f)))
+(define-public qtlreaper
+ (package
+ (name "qtlreaper")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/qtlreaper/qtlreaper-" version ".tar.gz"
+ ;; "http://downloads.sourceforge.net/project/qtlreaper/qtlreaper/1.1.1/qtlreaper-1.1.1.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fqtlreaper%2Ffiles%2Flatest%2Fdownload&ts=1358975786&use_mirror=iweb"))
+ ))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rbf030940nbbbkggdq2dxiy3c0jv8l4y3vvyfxhqimgj0qv3l1x"))))
+ (build-system python-build-system)
+ ;; (native-inputs
+ ;; `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no 'setup.py test'
+ (home-page "http://qtlreaper.sourceforge.net/")
+ (synopsis "Tool for scanning expression data for QTLs")
+ (description
+ "Batch-oriented version of WebQTL. It requires, as input,
+expression data from members of a set of recombinant inbred lines and
+genotype information for the same lines. It searches for an
+association between each expression trait and all genotypes and
+evaluates that association by a permutation test. For the permutation
+test, it performs only as many permutations as are necessary to define
+the empirical P-value to a reasonable precision. It also performs
+bootstrap resampling to estimate the confidence region for the
+location of a putative QTL.")
+ (license license:gpl2+)))
+
(define-public genenetwork1
(let ((commit "d622c803b"))
(package