aboutsummaryrefslogtreecommitdiff
path: root/gn/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner2020-06-25 15:24:15 +0300
committerEfraim Flashner2020-06-25 15:24:28 +0300
commit793f831f84ab67081e57bc8ec58d9927c019feb5 (patch)
tree837bd516a7383fd21e28aba8fc355ecd1bca938d /gn/packages/bioinformatics.scm
parent5d9a14c032026f7b9a77c1bcb86a5f86d1991a6a (diff)
downloadguix-bioinformatics-793f831f84ab67081e57bc8ec58d9927c019feb5.tar.gz
gn: Update bh20-seq-resource to 1.0-3.ae4cb3c.
Diffstat (limited to 'gn/packages/bioinformatics.scm')
-rw-r--r--gn/packages/bioinformatics.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gn/packages/bioinformatics.scm b/gn/packages/bioinformatics.scm
index d4c6e00..fc2c923 100644
--- a/gn/packages/bioinformatics.scm
+++ b/gn/packages/bioinformatics.scm
@@ -1226,10 +1226,9 @@ runApp(launch.browser=0, port=4206)~%\n"
"")
(license #f)))
-;; Note this package is incomplete. Needs more to run properly.
(define-public bh20-seq-resource
- (let ((commit "bbca5ac9b2538e410efe3e09651f87e5573145de")
- (revision "2"))
+ (let ((commit "ae4cb3c2cf7103bbc84f52618bb755d7ce25775b")
+ (revision "3"))
(package
(name "bh20-seq-resource")
(version (git-version "1.0" revision commit))
@@ -1240,22 +1239,30 @@ runApp(launch.browser=0, port=4206)~%\n"
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1kkysjgmhp7kfb17470ik821p9djsidyqmkbjvv37jx2w9pvw31z"))))
+ (base32 "1k0gsz4yc8l5znanzd094g2jp40ksbpa9667zr31ayrjx6labz02"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "setup.py"
+ (("py-dateutil") "python-dateutil"))
+ #t))))
(build-system python-build-system)
- (inputs
+ (propagated-inputs
`(("python-arvados-python-client" ,python-arvados-python-client)
+ ("python-dateutil" ,python-dateutil)
("python-flask" ,python-flask)
("python-magic" ,python-magic)
("python-pyyaml" ,python-pyyaml)
("python-pycurl" ,python-pycurl)
("python-pyshex" ,python-pyshex)
+ ("python-ruaml.yaml" ,python38-ruaml.yaml-0.15.76)
("clustalw" ,clustalw)
("python-schema-salad" ,python-schema-salad)))
(native-inputs
`(("git" ,(@ (gnu packages version-control) git))
("python-oauth2client" ,python-oauth2client)
- ("python-pytest" ,python-pytest)
- ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest-4)
+ ("python-pytest-runner" ,python-pytest-runner-2)
("python-uritemplate" ,python-uritemplate)))
(home-page "https://github.com/arvados/bh20-seq-resource")
(synopsis